"Error 1719: The Windows Installer service could not be accessed" error message when you try to add or remove a program (315346)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows XP Professional x64 Edition

This article was previously published under Q315346
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you try to add or remove a program, you may receive the following error message:
Error 1719. The Windows Installer Service could not be accessed. You may be running in safe mode or Windows Installer may not be correctly installed.

CAUSE

This behavior may occur if the following conditions are true:
  • The Windows Installer files that are on your hard disk are damaged or are missing.
  • You install or remove a program that uses the Windows Installer Microsoft Software Installation (MSI) package file (.msi). For example, this may occur when you try to install Microsoft Office on your computer.

RESOLUTION

To resolve this behavior, use the following methods.

Method 1: Re-register the Windows Installer

To re-register the Windows Installer, verify the location of the Msiexec.exe file on your hard disk and in the Windows Registry, and then re-register the Windows Installer. To do so:

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Verify the location of the Msiexec.exe file on your hard disk. To do so:
    1. Click Start, and then click Search.
    2. Click All files and folders.
    3. In the File name box, type msiexec.exe, and then click Search.
    4. In the search results, make a note of the location of the Msiexec.exe file.

      The location of the Msiexec.exe file should be similar to the following example, where Drive is the drive where Windows is installed, and %Windir% is the folder where Windows is installed:

      Drive:\%Windir%\System32

      An example of this is C:\Windows\System32.

      Note In Microsoft Windows 98-based computers, the Msiexec.exe file is located in the Drive:\%Windir%\System folder.
    5. On the File menu, click Close.
  2. Verify the location of the Msiexec.exe file in the Windows Registry. To do so:
    1. Click Start, and then click Run.
    2. In the Open box, type regedit, and then click OK.
    3. Locate, and then click the following registry key:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer

    4. In the right pane, double-click ImagePath.
    5. In the Edit String dialog box, make sure that the string in the Value data box contains the correct path of the Msiexec.exe file on your hard disk that you determined earlier in step 1.

      For example, if the Msiexec.exe file is located in the Drive:\Windows\System32 folder on your hard disk, the correct path of the Msiexec.exe file in the Value data box is the following path, where Drive is the drive where Windows is installed:

      Drive:\Windows\System32\Msiexec.exe /V

      Note If you are using Windows 98, the correct path of the Msiexec.exe file is Drive:\Windows\System\Msiexec.exe /V.

      If the Value data box does not contain the correct path, make the appropriate changes to correct the path, and then click OK.
    6. Quit Registry Editor.
  3. Start your computer in safe mode, and then register the Msiexec.exe file. To do so:
    1. Shut down, and then restart your computer.
    2. Press F8 after you receive the following message: Please select the operating system to start
    3. On the Windows Advanced Option menu, use the arrow keys to select Safe Mode, and then press ENTER.
    4. If you use a dual-boot or multiple-boot computer, select the appropriate operating system from the list that is displayed, and then press ENTER.
    5. Log on to the computer.
    6. Click Start,, click Run, type the following line, and then click OK:

      msiexec /regserver



      Note For 64-bit operating systems, you also need to reregister the 64-bit MSI installer. To do this, click Start, click Run, type the following line, and then click OK:

      Drive:\Windows\Syswow64\Msiexec /regserver
  4. Shut down, and then restart your computer in standard mode.
If the issue persists and you still receive the error message that is described earlier in the "Symptoms" section, follow the steps in Method 2.

Method 2: Reinstall the Windows Installer

To reinstall the Windows Installer, rename the damaged Windows Installer files, and then reinstall the Windows Installer. To do so:
  1. Click Start, and then click Run.
  2. In the Open box, type cmd, and then click OK.
  3. At the command prompt, type the following line, and then press ENTER, where Drive is the drive where Windows is installed and where %Windir% is the folder where Windows is installed:

    attrib -r -s -h drive:\%Windir%\system32\dllcache

    For example, type

    attrib -r -s -h c:\windows\system32\dllcache

    Note If you are using Windows 98, type system instead of system32.
  4. At the command prompt, type the following lines, pressing ENTER after each line:

    ren msi.dll msi.old
    ren msiexec.exe msiexec.old
    ren msihnd.dll msihnd.old

  5. At the command prompt, type exit, and then press ENTER.
  6. Restart your computer.
  7. Update the Windows Installer files on your hard disk to the latest version. Windows Installer 2.0 is available for download from the Microsoft Download Center. For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

    119591 How to obtain Microsoft support files from online services

    Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.
  8. Shut down your computer, and then restart it in standard mode.

MORE INFORMATION

For more information about Windows Installer technology, visit the following Microsoft Developer Network (MSDN) Web site: For more information about how to obtain the Windows Installer engine, click the following article number to view the article in the Microsoft Knowledge Base:

292539 How to obtain the Windows Installer engine


Modification Type:MajorLast Reviewed:10/16/2006
Keywords:kberrmsg kbprb KB315346