Log files are missing from the Web Server Logs dialog box in DTS Logs Import Property (314968)



The information in this article applies to:

  • Microsoft Commerce Server 2000 SP2
  • Microsoft Commerce Server 2002, Service Pack 3 (SP3)

This article was previously published under Q314968

SYMPTOMS

The Data Transformation Services (DTS) task, Web server log import (Commerce Server), has a View Log Files button on the property page. If you click this button, a Web Server Logs dialog box opens that contains a list of files that is based on the import criteria; however, some files may be missing from this list even though they meet all of the import criteria.

CAUSE

This problem occurs because the Use local time for file naming and rollover option is not supported by Commerce Server 2000. Log import is based on having one full day (Greenwich mean time) in each log file. If you create Internet Information Services (IIS) logs by using this option, a Greenwich mean time day is separated into two log files. To verify this, open a log file and check the first and the last entry.

RESOLUTION

To resolve this problem, do not use local time for IIS logging:
  1. Open Commerce Server Manager.
  2. Click Internet Information Server, and then click Server.
  3. Click Default Web Site, and then click Properties.
  4. Click the Properties button in the Logging section on the Web Site tab.
  5. On the Extended Logging Properties General Properties tab, click to clear the Use local time for file naming and rollover check box.
After a log file is created, the only way to change it is to manually modify Enddate TimeStamp in SiteSummary table of the Data Warehouse.

Modification Type:MajorLast Reviewed:9/9/2005
Keywords:kbfix kbprb KB314968