Internet Explorer 4.x on Windows 98 Clients Unexpectedly Disconnects from an SSL Connection (314524)



The information in this article applies to:

  • Microsoft Internet Explorer 4.01 for Windows 98 SP 1
  • Microsoft Internet Explorer 4.0 for Windows 98

This article was previously published under Q314524

SYMPTOMS

Internet Explorer 4.01 Service Pack 1 (SP1) or earlier that is running on a Microsoft Windows 98-based or Microsoft Windows 98 Second Edition-based computer may be unable to fully load or render Secure Socket Layer (SSL) Web pages (HTTPS). This behavior is most notable with images and graphics that partially load or do not load at all.

CAUSE

This behavior is due to limitations in earlier revisions of the Schannel.dll file that are included in versions of Internet Explorer 4.x and earlier. Because of these limitations, you could experience timeout issues and connectivity failures that are resolved in later revisions of Internet Explorer.

RESOLUTION

To resolve this behavior, upgrade to Internet Explorer version 5.5 Service Pack 2 (SP2) or later to help ensure the availability of hotfix support and the latest security updates from Microsoft. For information about how to obtain Internet Explorer version 5.5 SP2 or later, please see the following Microsoft Web site:

MORE INFORMATION

For more information about the Product Support Discontinuance as it refers to Internet Explorer 4.01 SP1, please see the following Microsoft Web site: From a Web server perspective, a server-side browser check can be implemented to determine the browser version and then redirect Internet Explorer 4.x clients to a Web site where an updated version can be obtained.

Modification Type:MajorLast Reviewed:10/9/2003
Keywords:kbenv kbprb KB314524