Group policies are not applied the way you expect; "Event ID 1058" and "Event ID 1030" errors in the application log (314494)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition

This article was previously published under Q314494
For a Microsoft Windows 2000 version of this article, see 259398.

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

On your Microsoft Windows XP-based computer, group policies may not be applied as you expect. When you view the application log of the event viewer, you see error data that is similar to the following: Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1058
Date: 2/8/2002
Time: 7:25:40 AM
User: NT AUTHORITY\SYSTEM
Computer: MYCOMPUTER
Description: Windows cannot access the file gpt.ini for GPO
CN={31B2F340-016D-11D2-945F-00C04FB984F9},CN=Policies,CN=System,DC=lcds,DC=lab
The file must be present at the location \\lcds.lab\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}
(Access is denied) Group Policy processing aborted.


Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1030
Date: 2/8/2002
Time: 7:30:46 AM
User: N/A
Computer: MYCOMPUTER
Description: Windows cannot query for the list of Group Policy objects. A message that describes the reason for this was previously logged by the policy engine.

CAUSE

This issue may occur if both of the following conditions are true:
  • Your Windows XP-based computer is a member of a domain.
  • The Microsoft Distributed File System (DFS) client is turned off.
Note The \\Active Directory Domain Name\Sysvol share is a special share that requires the DFS client to make a connection.

Note This issue may also occur if "Everyone" has been removed from the root drive NTFS file system permissions. If "Everyone" has been removed from the root drive NTFS permissions, restore the "Everyone" group's NTFS permissions on the root folder by granting "Everyone" the special Read and Execute NTFS permissions on the root folder only.

RESOLUTION

To resolve this issue, turn on the DFS client. To do this, follow these steps.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, and then click Run.
  2. In the Open box, type regedt32, and then click OK.
  3. In the Registry Editor window, locate the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Mup

  4. In the right details pane, double-click DisableDFS.

    The DFS client is turned off if the value in the Value data box is 1.
    The DFS client is turned on if the value in the Value data box is 0.
  5. In the Edit DWORD Value dialog box that appears, type 0 in the Value data box, and then click OK.
  6. On the File menu, click Exit to quit Registry Editor.
Additionally, turn on File and Printer Sharing for Microsoft Networks on the interface. To do this, follow these steps:
  1. Click Start, point to Connect To, and then click Show all connections.
  2. Right-click the appropriate connection, and then click Properties.
  3. Click the General tab.
  4. Under This connection uses the following items, verify that the check box next to File and Printer Sharing for Microsoft Networks is selected, and then click OK.

MORE INFORMATION

For additional information about problems that may occur when Windows applies group policies, click the following article number to view the article in the Microsoft Knowledge Base:

814112 Files on network shares Open slowly or read-only or you receive an error message

Under this scenario on a Microsoft Windows 2000-based computer, you receive the following event IDs:
  • UserEnv Event ID 1000SceCli Event ID 1001
These are different from the event IDs that you receive on a Windows XP-based computer.

Modification Type:MajorLast Reviewed:8/20/2004
Keywords:kbEventLog kbEvent kbRegistry kbDFS kberrmsg kbprb KB314494 kbAudITPRO