"Event ID: 7000" or "Event ID: 7013" Error Message When You Attempt to Start a Service (314357)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q314357
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When a service does not start because of a logon failure, you may receive either of the following error messages in the system event log after you restart the computer (where ServiceName is the name of the service in question):
Source: Service Control Manager
Event ID: 7000
Description:
The ServiceName service failed to start due to the following error:
The service did not start due to a logon failure.

No Data will be available.

-or-

Source: Service Control Manager
Event ID: 7013
Description:
Logon attempt with current password failed with the following error:
Logon failure: unknown user name or bad password.

No Data will be available.
When you attempt to manually start the service, you may receive the following error message:
Microsoft Management Console
Could not start the ServiceName service on Local Computer
Error 1069: The service did not start due to a logon failure.
NOTE: You may receive these error messages even though the user account is valid.

CAUSE

This behavior can occur if you configure the service to log on to a user account, and any of the following conditions are true:
  • The right to log on as a service is revoked for the specified user account.
  • The password is changed on the user account that the service uses to log on.
  • The password data in the registry is damaged.

RESOLUTION

To resolve this issue, use the following methods, as appropriate to your circumstances.

Method 1: Configure User Rights

NOTE: This method is for Windows XP Professional only, not for Windows XP Home Edition.

If the right to log on as a service is revoked for the specified user account, restore the right by using either of the following methods, as appropriate to your situation.

On a Domain Controller

If the user is in an Active Directory domain, follow these steps:
  1. Log on to the domain controller as administrator.
  2. Start the Active Directory Users and Computers snap-in.
  3. Right-click the organizational unit (OU) in which the user right to log on as a service is granted, and then click Properties.

    By default, this is in the Domain Controllers OU.
  4. Click the Group Policy tab.
  5. Click Default Domain Controllers Policy, and then click Edit.
  6. Expand Computer Configuration, expand Windows Settings, and then expand Security Settings.
  7. Expand Local Policies, and then click User Rights Assignment.
  8. In the right pane, right-click Log on as a service, and then click Security.
  9. Add the user that you want to the policy, and then click OK.
  10. Quit the Group Policy Editor, click OK, and then close the Active Directory Users and Computers snap-in.

On a Local Computer

If the user is on a stand-alone Windows XP-based computer, follow these steps:
  1. Log on to the computer as administrator or as a member of the Administrators group.
  2. Start the Local Computer Policy snap-in.
  3. Expand Local Computer Policy, expand Computer Configuration, expand Windows Settings, and then expand Security Settings.
  4. Expand Local Policies, and then click User Rights Assignment.
  5. In the right pane, right-click Log on as a service, and then click Properties.
  6. Click Add User or Group, add the user that you want to the policy, and then click OK twice.
  7. Close the Local Computer Policy snap-in.

Method 2: Configure Logon Information for the Service

If the password is changed on the user account that the service uses to log on, configure the password to match the current password for that user. To do this, follow these steps:
  1. Click Start, click Control Panel, click Performance and Maintenance, and then click Administrative Tools.
  2. Double-click Services.
  3. In the right pane, right-click the appropriate service, and then click Properties.
  4. Click the Log On tab, type the correct password in the Password and Confirm Password boxes, and then click OK.
  5. Right-click the service, and then click Restart.
  6. Quit the Services tool.

Method 3: Configure the Service to Use the Built-in System Account

If the service still does not work with the specified user account, configure the service to log on to the built-in system account. To do this, follow these steps:
  1. Click Start, click Control Panel, click Performance and Maintenance, and then click Administrative Tools.
  2. Double-click Services.
  3. In the right pane, right-click the appropriate service, and then click Properties.
  4. Click the Log On tab, click Local System account, and then click OK.

    NOTE: In most situations, it is not necessary to configure a service to interact with the desktop. You do not need to select the Allow service to interact with desktop check box.
  5. Right-click the service, and then click Restart.
  6. Quit the Services tool.
When you attempt to open the properties of a service by using the Services tool in Control Panel, the computer may stop responding (hang) and/or you may receive the following error message:
The RPC Server is unavailable.
You may receive this error message if the remote procedure call (RPC) service is not started because of a logon failure with that service or a dependency service. Some services have dependency services, and these services do not start until their dependency services start first (for example, the Workstation service).

If you cannot start the Services tool, use Registry Editor to configure the service to use the built-in system account. To do this, follow these steps:
  1. Click Start, and then click Run.WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

  2. In the Open box, type regedt32, and then click OK.
  3. Locate the following registry key, where ServiceName is the service that you want to configure:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ServiceName

  4. In the right pane, double-click ObjectName.
  5. In the Edit String dialog box that appears, type localsystem, and then click OK.
  6. On the File menu, click Exit to quit Registry Editor.
  7. Click Start, click Control Panel, click Performance and Maintenance, and then click Administrative Tools.
  8. Double-click Services.
  9. Right-click the service, and then click Restart.

    You may need to restart the computer for some services to restart properly.

MORE INFORMATION

Although most system services log on to the local system account by default, you can configure services to use a specific user account and password. If you choose to specify a user account and password, it is important that the account name and password remain constant. When a user's password is changed, the password information is not automatically updated for the service.

For example, the user account that the service uses should not be required to change its password or be renamed. If these two events (or other similar events) occur, you must also update the logon credentials for the service.

For additional information about how to view and manage event logs in Event Viewer, click the article number below to view the article in the Microsoft Knowledge Base:

308427 HOW TO: View and Manage Event Logs in Event Viewer


Modification Type:MinorLast Reviewed:4/22/2004
Keywords:kbRegistry kbenv kberrmsg kbprb KB314357 kbAudITPRO