Cannot Set Print Options for Gateway Services for NetWare Clients (314264)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2

This article was previously published under Q314264

SYMPTOMS

Gateway Services for NetWare (GSNW) provides clients that are not running any NetWare client software with the ability to print to printers that are connected to a NetWare server. Clients that print to these printers always receive the default print options including printing of a banner page and a trailing form feed, even if you try to alter this behavior in the GSNW tool in Control Panel. However, users that log on to the GSNW server can set and use the print options properly.

CAUSE

GSNW on Windows 2000 always uses the default print options for print jobs that come through the gateway service.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

The English version of this fix should have the following file attributes or later:
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   10-Jan-2002  10:29  5.0.2195.4820  135,000  Nwprovau.dll
				


IMPORTANT: After you install the hotfix that is described in this article and restart the server, you must complete the following procedure:
  1. Log on to the GSNW server as the gateway user (the user account that was used to enable the gateway in the Enable Gateway dialog box in the GSNW tool in Control Panel).
  2. Set the desired print options in the GSNW tool in Control Panel.
  3. Log off of the server.
All GSNW clients now receive the same print options as the gateway user's print options that you previously configured.

NOTE: The Windows gateway user account must match the user account entered in the Enable Gateway dialog box in the GSNW tool in Control Panel. This user account must also have local administrative rights on the GSNW server.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:

296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot

For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:

249149 Installing Microsoft Windows 2000 and Windows 2000 Hotfixes

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kb3rdparty kbbug kbenv kbfix kbprint kbui kbWin2000PreSP3Fix kbWin2000sp3fix KB314264