Money: "Kernel32.dll" or "Msofd.dll" Error Message When You Quit Money (314136)



The information in this article applies to:

  • Microsoft Money 2003 Standard
  • Microsoft Money 2003 Deluxe
  • Microsoft Money 2003 Deluxe and Business
  • Microsoft Money 2002
  • Microsoft Money 2001 Deluxe and Business
  • Microsoft Money 2001
  • Microsoft Money 2000 Business and Personal
  • Microsoft Money 2000 Deluxe
  • Microsoft Money 2000
  • Microsoft Money 2004 Deluxe

This article was previously published under Q314136

SYMPTOMS

When you try to quit Money, you may receive either of the following error messages:
MSMoney has caused an error in kernel32.dll. MSMoney will now close.
MSMONEY caused an exception 10H in module MSOFD.DLL.

CAUSE

This behavior can be caused by a damaged installation of Microsoft Internet Explorer.

RESOLUTION

To resolve this issue, use the following methods in the order in which they are presented.

Method 1: Repair Internet Explorer

Use the Internet Explorer Repair tool to verify that the installation of Internet Explorer is damaged.

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs, and then click the Install/Uninstall tab.
  3. In the list of installed programs, click Microsoft Internet Explorer and Internet Tools, and then click Add/Remove.
  4. Click Repair the current installation of Internet Explorer, and then click OK.
If the Internet Explorer Repair tool detects an error, you may receive an error message similar to the following:
Internet Explorer cannot be repaired. Please reinstall Internet Explorer.
If you click Details, one of the following messages may be displayed:
  • Internet Explorer cannot be repaired due to the following errors: File file name is missing.
  • Internet Explorer cannot be repaired due to the following errors: Version nnn of file file name exists but needs to be greater than nnn. In order to fix a problem of this nature, it is recommended that Internet Explorer be re-installed.
For additional information about the Internet Explorer Repair tool, click the article number below to view the article in the Microsoft Knowledge Base:

194177 Description of the Internet Explorer Repair Tool

If this issue continues to occur, proceed to the next method.

Method 2: Uninstall and Reinstall Internet Explorer

To uninstall and reinstall Internet Explorer, follow these steps.

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs, and then click the Install/Uninstall tab.
  3. In the list of installed programs, click Microsoft Internet Explorer and Internet Tools, and then click Add/Remove.
  4. Click Restore the previous Windows configuration, or click Advanced to specify any additional components that you want to remove.
  5. Click OK.
  6. Click OK to restore the previous version of Internet Explorer and shared components. If you are prompted to verify that you want to restore the previous version, click Yes.
  7. When you are prompted to restart the computer, do so.
  8. Insert the Money CD-ROM while you hold down the SHIFT key. Holding down the SHIFT key prevents the Money Setup program from starting automatically.
  9. Browse to the IE folder on the CD-ROM.
  10. In the IE folder, double-click IE5Setup.EXE. Follow the instructions on the screen to install Internet Explorer.
If you cannot remove Internet Explorer in step 5, install the latest version of Internet Explorer from the following Microsoft Web site: If this issue continues to occur, proceed to the next method.

Method 3: Reinstall Money

To uninstall and reinstall Microsoft Money, follow these steps.

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs, and then click the Install/Uninstall tab.
  3. In the list of installed programs, click Microsoft Money, and then click Add/Remove.
  4. When you are prompted to remove Microsoft Money from your computer, click Yes.
  5. Follow the instructions on the screen to uninstall Microsoft Money.
  6. If you are prompted to restart your computer, click No.
  7. Repeat steps 3 through 5 for each listing of Money that you have.
  8. If you are prompted to restart your computer after you remove the last listing of Money, click Yes.
  9. Reinstall Money from your Money CD-ROM.

Modification Type:MinorLast Reviewed:1/7/2006
Keywords:kbprb KB314136