Non-Administrative Users Cannot Start Outlook 2000 After You Upgrade to Windows XP (313982)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q313982

SYMPTOMS

If you install Microsoft Office 2000, and then upgrade to Windows XP Professional, if you log on as a user who does not have administrative rights, and then start Outlook, you receive a message that states that the operating system has migrated. However, if you click OK, Windows Installer starts, and you may receive the following error message:
Microsoft Office 2000 SR-1 Premium
----------------------------------
Error 1706. No valid source could be found for product Microsoft Office 2000 SR-1 Premium. The Windows Installer cannot continue.
If you click OK, the Windows Installer status bar runs backwards quickly, and you receive the following error message:
Microsoft Outlook
-----------------
Outlook was unsuccessful in configuring itself for your new version of Windows. Please perform a Detect and Repair, available on the Help menu. If this is not successful, you must reinstall Outlook 200.
If you click OK, Windows Installer looks like it is starting again. However, you receive the "error 1706" error message again. If you click OK, you receive the following error message:
Microsoft Outlook
-----------------
Cannot start Microsoft Outlook. MAPI32.DLL is corrupt or the wrong version. This could have been caused by installing other messaging software. Please reinstall Outlook.

If you click OK, you receive a Dr. Watson error message that prompts you to send the information to Microsoft.

CAUSE

This problem may occur because if you upgrade from either Microsoft Windows 95, Microsoft Windows 98, or Microsoft Windows 98 Second Edition to Windows XP, the AllowLockdownMedia policy setting is not set. If you disable profiles in either Windows 95, Windows 98, or Windows 98 Second Edition, install Office, and then upgrade to Windows XP, the Office installation becomes a program that you manage on each individual computer. Therefore, users who are not administrators cannot perform any installations from a compact disc (CD). The same behavior occurs with all other AllowLockdown policy settings (including AllowLockdownBrowse and AllowLockdownPatch).

RESOLUTION

To resolve this problem, either set the AllowLockdownMedia Windows Installer policy setting or make the user an administrator before they run Outlook for the first time. To set the AllowLockdownMedia policy setting, add an AllowLockdownMedia DWORD value to the following registry key and set its value data to 1.

HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer

Follow these steps, and then quit Registry Editor:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key in the registry:

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer

  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type AllowLockdownMedia, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. Type 1, and then click OK.
For more information about the AllowLockdownMedia policy setting, visit the following Microsoft Web site:

STATUS

Microsoft has confirmed that this is a problem in Windows 2000 and Windows XP.

MORE INFORMATION

The problem that is described in the "Summary" section of this article may occur in the following scenario:
  1. Install Windows 98 Second Edition, and then join a domain.
  2. Install Office 2000 SR-1 from the CD, start Outlook, and then set up an Exchange Server account.
  3. Upgrade to Windows XP.
  4. Log on as an administrator, and then start Outlook.

    Outlook runs its post-migration configuration. You must have the Office 2000 SR-1 CD in the CD drive. (Leave the CD in the CD drive for the rest of the steps.)
  5. Create a user account, and then log off the administrator's account.
  6. Log on to the user account, and then start Outlook from the Start menu.
You receive the error messages that are described in the "Symptoms" section of this article.

Modification Type:MajorLast Reviewed:1/14/2003
Keywords:kbprb KB313982