PRB: The Error "Cannot Open .pst File" Occurs When You Use a POP3 Server Profile with SQL Mail (313969)



The information in this article applies to:

  • Microsoft SQL Server 2000 (all editions)
  • Microsoft SQL Server 7.0

This article was previously published under Q313969

SYMPTOMS

When you are using Terminal Services client to log on to a computer, you receive the following error message:
Can not open the PST because it is in use.
You can receive this error message in either of the following two scenarios:
  • If SQL Server Agent or SQL Mail (or both) is configured to use a Post Office Protocol 3 (POP3) mail profile and you try to open Microsoft Outlook by using the same profile.
  • If you try to start SQL Server Agent at the same time that an Outlook client that is using a POP3 mail profile is open, and SQL Mail is configured to use the same profile as the Outlook client.
In a different situation where one of the processes (Outlook or SQL Server Agent or SQL Mail) actually modifies the .pst file (such as by sending an email or creating a new folder), you might receive the following error message when the other process is trying to access that .pst file:
"The file 'path and filename'.PST could not be accessed because another workstation has modified it. Close then restart all mail-enabled applications."

CAUSE

Only one user application at a time can access a .pst file.

WORKAROUND

To work around this behavior, use any of the following methods:
  • To successfully access the .pst file when you connect through Terminal Services client to use Outlook:
    1. Stop the MSSQLSERVER service.
    2. Start Outlook, check your mail, and then exit Outlook.
    3. Restart the MSSQLSERVER service.
  • You can also access the .pst file without stopping the MSSQLSERVER service. Instead of Terminal Services, (which opens a second session with the same account) use Remote Desktop Sharing (for Microsoft Windows XP only), Microsoft NetMeeting, or third-party remote computer management products. By doing so, you can log on to the computer under the same user context that is currently running on the computer itself.
  • To avoid the problem completely, use separate profiles for Outlook and SQL Mail or SQL Server Agent, which in turn use separate .pst files.
  • You can also use Microsoft Exchange Server as your mail server, in which case a .pst file is not used and multiple user contexts can access a mailbox at the same time.

STATUS

This behavior is by design.

Modification Type:MajorLast Reviewed:10/17/2003
Keywords:kbprb KB313969