FIX: Spanish Version of VFP 7.0 Does Not Put Product ID in Registry (313921)



The information in this article applies to:

  • Microsoft Visual FoxPro for Windows 7.0

This article was previously published under Q313921

SYMPTOMS

You cannot obtain the product ID from the Help About dialog box or from Visual FoxPro (VFP) language functions.

CAUSE

The Spanish version of Visual FoxPro 7.0 does not write the product ID into the Windows registry. The setup routine that installs the Spanish version sets the HKLM\Software\Microsoft\VisualFoxPro\7.0\Registration\ProductID value to "".

RESOLUTION

To resolve this problem, obtain the latest service pack for Visual FoxPro for Windows 7.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

316964 How to Obtain the Latest Visual FoxPro for Windows 7.0 Service Pack

STATUS

Microsoft has confirmed that this is a problem in Microsoft Visual FoxPro for Windows 7.0. This problem was first corrected in Visual FoxPro for Windows 7.0 Service Pack 1.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Install the Spanish version of VFP 7.0 on any operating system. The operating system can be any language version.
  2. From the System menu, click Help, and then click About Microsoft Visual FoxPro. Note that the Product ID field is blank.
Because the registry key mentioned in the "Cause" section contains "", SYS(9) and VERSION(1) return nothing.

Modification Type:MajorLast Reviewed:3/6/2002
Keywords:kbbug kbDSupport kbsetup KB313921