You Cannot Open Saved Event Log Files on Computers That Do Not Run Windows 2000 (313689)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2

This article was previously published under Q313689

SYMPTOMS

Administrators can use Event Viewer to save event logs to files. If you save such a file on a network server or Network Access server (NAS) device that is not Windows 2000-based, Event Viewer cannot open the event log file.

If you try to open a saved event log file on a network server or NAS device that is not Windows 2000-based, you can see the file and select it. However, the Log Type box is not filled with the event log types, so you cannot select a log type. You receive an error message when you click the Open button. The error message indicates that you must select a log type. However, there are no event log types to select.

CAUSE

The tool tries to read the supported event log types from the registry on the remote computer. If the remote computer does not run Microsoft Windows NT 4.0 or Windows 2000, there is no registry on the remote computer to read.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

The English version of this fix should have the following file attributes or later:
   Date         Time   Version        Size     File name
   -----------------------------------------------------
   11-DEC-2001  14:34  5.0.2195.4749  157,456  Els.dll
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:

296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot


Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbSysAdmin kbWin2000PreSP3Fix kbWin2000sp3fix KB313689