Your Windows 2000-based computer may stop responding during hardware detection (313598)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2

This article was previously published under Q313598

SYMPTOMS

Your Microsoft Windows 2000-based computer may stop responding during hardware detection.

CAUSE

This problem is caused by an infinite loop that may occur when the Windows 2000 kernel enumerates the hardware devices that are attached to the system.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to obtain the latest Windows 2000 service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   07-Dec-2001  20:59  5.0.2195.4743   1,686,528  Ntkrnlmp.exe     
   07-Dec-2001  21:01  5.0.2195.4743   1,686,208  Ntkrnlpa.exe     
   07-Dec-2001  21:01  5.0.2195.4743   1,706,880  Ntkrpamp.exe     
   07-Dec-2001  20:59  5.0.2195.4743   1,664,320  Ntoskrnl.exe     
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Windows 2000 Service Pack Service Pack 3.

REFERENCES

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

265173 The Datacenter program and Windows 2000 Datacenter Server product

296861 How to install multiple Windows updates or hotfixes with only one reboot

249149 Installing Microsoft Windows 2000 and Windows 2000 hotfixes


Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbOSWin2000fix kbWin2000PreSP3Fix kbWin2000sp3fix KB313598 kbAudITPRO kbAudEndUser