BUG: Visual Studio .NET Samples and Managed Tools Do Not Work Properly When Installed on a Mapped Network Drive (313517)



The information in this article applies to:

  • Microsoft .NET Framework SDK 1.0
  • Microsoft .NET Framework Class Libraries 1.0
  • Microsoft .NET Framework 1.1

This article was previously published under Q313517

SYMPTOMS

When you install the .NET Framework software developer's kit (SDK) to a mapped network drive, it installs with no errors. However, if you install the included samples and managed tools to a mapped network drive, these features may not work properly.

Note Although you can install the SDK to a network drive, this is not supported. Installed tools and samples built from a network drive are not guaranteed to run properly.

CAUSE

A network drive is considered part of the local intranet zone in terms of code access security. If the default security policy is in place, some managed code and any SDK samples that contain managed code do not run correctly in this zone, or they do not run at all.

Additionally, tools installed to the network drive do not have the proper registry entries on the local machine, because these registry entries cannot be set during the installation process. As a result, they do not run correctly. This behavior also occurs when the tools are copied locally.

RESOLUTION

To ensure that all tools run correctly, install the SDK locally.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For more information about how to run managed code under code access security, browse to the following Microsoft Web site:

REFERENCES

To install the Platform SDK and documentation, browse to the following Microsoft Web site: The documentation is also available from the MSDN Library at the following Microsoft Web site:

Modification Type:MinorLast Reviewed:5/28/2003
Keywords:kbSample kbprb KB313517 kbAudDeveloper