"Windows Installer error 1606" error message when you try to start Help in Office 2000 programs (313257)



The information in this article applies to:

  • Microsoft Excel 2000
  • Microsoft Access 2000
  • Microsoft FrontPage 2000
  • Microsoft Outlook 2000
  • Microsoft PowerPoint 2000
  • Microsoft Publisher 2000
  • Microsoft Word 2000

This article was previously published under Q313257

SYMPTOMS

When you attempt to start Help in Microsoft Outlook 2000, you may receive an error message similar to the following:
Microsoft Outlook cannot display Office Assistant Help. Microsoft Outlook cannot install the necessary files due to Windows Installer error 1606.
You may also receive a similar error message in other Microsoft Office 2000 programs when you attempt to start Help.

CAUSE

This behavior can occur if the Windows Installer files are damaged or are not installed correctly. As a result, the Windows Installer requests a file that is installed only as part of the Microsoft Office 2000 Service Release 1 (SR-1) patch, even if the version of Office 2000 installed on your computer is the original release. When the Windows Installer attempts to replace the missing component, the procedure is unsuccessful because the SR-1 patch is not installed, and therefore you receive the error message described in the "Symptoms" section.

RESOLUTION

To resolve this issue, follow these steps:
  1. Install the latest version of the Windows Installer. To do this, browse to one of the following Microsoft Web sites, as appropriate to your operating system.

    Microsoft Windows 95 or Microsoft Windows 98Microsoft Windows NT 4.0NOTE: On a Windows XP-based computer or a Windows 2000-based computer, you do not need to install the Windows Installer Update.

  2. Obtain and run the Office 2000 SR-1a Update. To do this, browse to the following Microsoft Web site to download the o2ksr1a.exe file from the Office Download Center:
  3. Double-click the o2ksr1.exe program file that you just downloaded to start the installation of SR-1.
  4. Follow the instructions on the screen to complete the installation.
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

MORE INFORMATION

Your version of the Windows Installer may be damaged if one or more of the following conditions are true:
  • Your computer's registry is corrupted.

  • You (or someone else) inadvertently change a registry setting used by the Windows Installer.

  • The installation of a program that uses the Windows Installer (for example, Microsoft Office 2000) is interrupted.

  • There are multiple instances of Setup.exe running simultaneously, or an instance of Setup.exe stops responding (hangs).

REFERENCES

For additional information about how to install the Office SR-1 Update, click the following article number to view the article in the Microsoft Knowledge Base:

245025 How to obtain and install the Microsoft Office 2000 SR-1/SR-1a update

For additional information about the Office SR-1a Update, click the following article number to view the article in the Microsoft Knowledge Base:

245021 List of fixed pcrosoft Office 2000 Service Release 1/1a (SR-1/SR-1a)

261933 What is the SR-1a Update?


Modification Type:MinorLast Reviewed:1/7/2006
Keywords:kbsetup kberrmsg kbprb KB313257