PRB: MSMQ Will Not Start After You Apply MQ9XSP6 (313009)
The information in this article applies to:
- Microsoft Message Queue Server (MSMQ) 1.0
This article was previously published under Q313009 SYMPTOMS
When you apply the IExpress package (Mq9xsp6.exe) to a computer running Windows 95, Windows 98, or Windows Millennium Edition (Me), the Microsoft Message Queue Server (MSMQ) process may fail to start. When you attempt to run an application, you may receive a "service not available" error message (C00E000B). In the MSMQ\Storage directory, the Msmqlog.txt file contains the "Can't Initialize the logger" error message.
CAUSE
The update for MSMQ that is distributed with Windows NT 4.0 Service Pack 6 (SP6) CD-ROM contains an updated Mqlogmgr.dll that requires a later version of Adme.dll. The Adme.dll file is a part of the DTC/MTS DLL, which you must update to support the new Mqlogmgr.dll by performing at least a minimal installation of Personal Web Server(PWS).
NOTE: This behavior can occur only when you use the Windows NT Server 4.0 Enterprise Edition CD-ROM, or a share created from that CD-ROM, to install MSMQ. When you use PWS to install MSMQ, PWS automatically installs the required DTC/MTS files.
RESOLUTION
Upgrade the computer by installing the Transaction Server update contained in the PWS for Windows 95, Windows 98, and Windows Me, which is available on the Web or on the Windows 98 CD-ROM. Beginning with the Windows 98 Second Edition CD-ROM, this application is located in the \Add-ons directory. You can perform a minimal install of PWS by performing a Custom install.
Modification Type: | Major | Last Reviewed: | 3/26/2002 |
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Keywords: | kbprb KB313009 |
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