PRB: HTTP error when you run the Learning BizTalk Server tutorial (313007)
The information in this article applies to:
- Microsoft BizTalk Server 2002
This article was previously published under Q313007 SYMPTOMS
When you run Lesson 7 of the Learning BizTalk Server tutorial, users may encounter the following error in the Windows 2000 Application Event Log:
An error occurred in BizTalk Server.
Details
-------------------------------
[0x80004005] An error occurred during transmission
Request Information:
Proxy:
Proxy port: 80
URL: http://SERVER/LearnBizTalk/ContosoReceive.asp
Content-Type: text/plain; charset="UTF-8"
User name:
Client Certificate:
Request body: 345 Bytes
Timeout duration (seconds): 91
Error code: 80004005
===== ERROR =====
The HTTP server returned an unexpected response: 401 Access Denied
CAUSE
This error occurs in a secured Web server environment if the Internet Guest User account (IUSR_computer name) that Microsoft Internet Information Server (IIS) uses has been restricted.
RESOLUTION
To resolve this problem, modify the sample so that it works in a secured Web server environment. To allow the sample to function without reducing security on the existing Web server, follow these steps before you run Lesson 7 of the Learning BizTalk Server tutorial:
- Open Microsoft Windows Explorer, and browse to the C:\LearnBizTalk folder.
- Right-click the Output folder, and then click Properties.
- In the Output Properties dialog box, on the Security tab, click Add.
- Click Look in, and select your computer or domain.
- In the Type names separated by semicolons or choose from list box, type your user name in the domain name\user name format. Type the password for this account, and then click Check Names.
- When your user name resolves, click OK. Notice that
your user account is added to the list of group names or user names.
- Under Permissions, select the Allow check box for both Read and Write, and clear any other permissions.
- Click Apply, and then click OK to close the Output Properties dialog box.
To resolve this problem, you must also modify the advanced properties for the "Channel to Contoso" and the "Channel to Northwind Invoice" channels.
- Open BizTalk Messaging Manager.
- In BizTalk Messaging Manager, in the Channel Name list, click Channel to Contoso.
- On the File menu, click Edit.
- In the Channel Property Wizard, click Next until you reach the Advanced Configuration page.
- On the Advanced Configuration page, click Advanced.
- In the Override Messaging Port Defaults dialog box, on the Primary Transport tab, click Properties.
- In the BizTalk Component Properties dialog box, in the User name text box, type your user name in the domain name\user name format. In the Password text box, type the password for your user account, and then click OK.
- Repeat steps 2 through 7 to modify the "Channel to Northwind Invoice" channel.
STATUSThis behavior is by design.
Modification Type: | Major | Last Reviewed: | 6/12/2006 |
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Keywords: | kbpending kbprb KB313007 |
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