ActiveSync Appears Connected After You Disconnect (312971)



The information in this article applies to:

  • Microsoft ActiveSync 3.6
  • Microsoft ActiveSync 3.5
  • Microsoft ActiveSync 3.1
  • Microsoft ActiveSync 3.0

This article was previously published under Q312971

SYMPTOMS

When you disconnect your device from your computer during ActiveSync synchronization, ActiveSync that is running on your computer and that was actively transferring data to or from the device may appear to stop responding (hang). ActiveSync may appear to do so for several seconds to six minutes.

CAUSE

The disconnect has interrupted a transaction and the desktop component on your computer is waiting for an acknowledgment that the last transmission was received correctly. The period of time that ActiveSync waits depends on the version of the Windows operating system that is running on your computer.

STATUS

This behavior is by design.

MORE INFORMATION

This behavior can occur with Universal Serial Bus (USB), serial, or network connections. This is because all connection types use remote procedure calls that are based on a reliable connection-configured windows sockets communication layer. To increase reliability, the subsystem retries several times before giving up, and this prevents the thread that sent the data from continuing.

Modification Type:MinorLast Reviewed:8/18/2005
Keywords:kbprb kbui KB312971 kbAudDeveloper