PI: Error Message: PIP Caused an Invalid Page Fault in Module GDIPlus.dll (312954)



The information in this article applies to:

  • Microsoft Picture It! Photo version 7
  • Microsoft Picture It! Photo Premium version 7
  • Microsoft Picture It! Digital Image Pro version 7
  • Microsoft Picture It! Photo 2002 1.0
  • Microsoft Picture It! Photo Premium 2002, version 1.0
  • Microsoft Picture It! Publishing 2002, Gold, version 1.0
  • Microsoft Picture It! Publishing Platinum 2002 1.0
  • Microsoft Digital Image Pro 9
  • Microsoft Digital Image Suite 9
  • Microsoft Picture It! Express 9
  • Microsoft Picture It! Photo Premium 9

This article was previously published under Q312954

SYMPTOMS

When you try to open graphic images in any one of the programs that are listed in the "Applies To" section, you may receive the following error message:
PIP caused an invalid page fault in module gdiplus.dll

CAUSE

This issue can occur if your computer uses Trident CyberBlade XP (69) video card and the drivers for the card are outdated.

This issue is known to occur on the following computers from Hewlett Packard:

HP Pavilion n5470
HP Pavilion n5430
HP Pavilion xh485
HP Pavilion xh455

RESOLUTION

To resolve this issue, update your video card drivers. For updated video card drivers for your computer, see the following Hewlett Packard Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Workaround

To work around this issue, reduce graphics hardware acceleration. Follow the steps appropriate for your operating system.

Microsoft Windows 98, Microsoft Windows 98 Second Edition, and Microsoft Windows Millennium Edition (Me)

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. Click the Performance tab, and then click Graphics.
  4. Move the Hardware Acceleration slider one notch to the left of the current setting.
  5. Click OK, and then click Close.
  6. When you are prompted to restart the computer, click Yes.
  7. Test to see whether the issue is resolved. If the issue continues to occur, repeat steps 1 through 6 until you reach the None setting or the issue is resolved.

Microsoft Windows 2000 or Microsoft Windows XP

  1. In Windows 2000, click Start, point to Settings, and then click Control Panel.

    In Windows XP, click Start, and then click Control Panel.
  2. Double-click Display.
  3. Click the Settings tab, click Advanced, and then click the Troubleshooting tab.
  4. Move the Hardware Acceleration slider one notch to the left of the current setting.
  5. Click OK, and then click Close.
  6. When you are prompted to restart the computer, click Yes.
  7. Test to see whether the issue is resolved. If the issue continues to occur, repeat steps 1 through 6 until you reach the None setting or the issue is resolved.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:7/18/2005
Keywords:kbprb KB312954