XADM: "Catastrophic Failure" Error Message When You Attempt to Change Mailbox Rights (312612)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q312612

SYMPTOMS

When you attempt to change the mailbox rights of a mailbox through the Users and Computers Microsoft Management Console (MMC) in Active Directory, you may receive the following error message:
A catastrophic failure has happened - can't assign permissions.

CAUSE

After a mailbox is created, the security descriptor for that mailbox moves from Active Directory to the information store. When a user wants to adjust a mailbox right, the user needs an access control entry (ACE) that grants the correct permissions to do that. In a scenario in which one user does not create a second user mailbox, the information store returns an "access denied" response, which is translated by Active Directory as a catastrophic failure.

STATUS

This behavior is by design.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kberrmsg kbprb KB312612