Windows Installer starts each time that a new user starts an Office 2000 program (312596)



The information in this article applies to:

  • Microsoft Office 2000 Premium
  • Microsoft Office 2000 Professoinal
  • Microsoft Office 2000 Standard
  • Microsoft Office 2000 Small Business
  • Microsoft Office 2000 Developer
  • Microsoft Access 2000
  • Microsoft Excel 2000
  • Microsoft FrontPage 2000
  • Microsoft Outlook 2000
  • Microsoft PowerPoint 2000
  • Microsoft Word 2000

This article was previously published under Q312596

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When a new user attempts to start a Microsoft Office program, the Windows Installer may start and attempt unsuccessfully to install the program.

CAUSE

This issue may occur if certain Office registry keys are missing. If the user starts an Office program by double-clicking an Office document, rather than by using the program name on the Start Menu, Office does not create the keys. Windows Installer starts and then attempts to repair these key. However, the Office installation point on the network is not available, and therefore, the installation is unsuccessful.

WORKAROUND

To work around this behavior, use the following methods in the order provided.

Method 1: Copy the Installation Files to the Local Computer

Copy the Office 2000 installation files from the administration point to a folder on the local computer. Now new users can gain access to the source files if they need them. If this method works, you do not have to go to method 2.

Method 2: Edit the Registry, and Then Copy an Administrator's Profile

Use the following method only as a last resort. This method may affect other programs on your computer. After following the steps in this method, you may have to reconfigure or reinstall other programs on your computer.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

To copy an administrator's profile to the default user group, follow these steps:
  1. Log on to the local computer as an administrator for whom the correct profile settings are configured.
  2. Click Start, and then click Run.
  3. In the Run box, type regedit, and then click OK.
  4. In Registry Editor, locate the following key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\UserInfo

  5. In the right pane, click UserID, and then click Delete on the Edit menu. Click Yes to confirm the deletion.
  6. Repeat steps 4 and 5 for the following values:

    UserInitials
    UserName

  7. Quit Registry Editor.
  8. Click Start, and then click Control Panel.
  9. Double-click System.
  10. Click the Advanced tab, and then under User Profiles, click Settings.
  11. Click the Administrator profile, click Copy to, and then click Browse.
  12. Locate Documents and Settings, and then click the user name folder to which you want to assign the administrator profile.
  13. Under the heading Permitted to use, click Change.
  14. In the Enter the object name to select box, enter the target user name, and then click OK. (If the target is 'Default User', select the '\Everyone' account.)
  15. Click OK twice, and then click Yes to confirm the copy.
  16. Restart the computer.

Modification Type:MinorLast Reviewed:10/13/2006
Keywords:kbstartprogram kbtshoot kbsetup kbprb KB312596