The event log stops logging events before reaching the maximum log size (312571)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition

This article was previously published under Q312571
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

The Event Log service may stop logging events before the size that is specified in the Maximum log size setting is reached if the Do not overwrite events option is turned on. This can cause events to be lost. The event log generally stops logging new events when the log reaches a size of from approximately 200 megabytes (MB) to 600 MB.

CAUSE

The Event Log service may report that the event log is full and stop logging events before the maximum log size is reached. If the "Shut down system immediately if unable to log security audits" Group Policy setting is in use on a computer, the computer may stop auditing events and may stop responding (hang) sooner than expected.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to obtain the latest Windows service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size    File name
   --------------------------------------------------------
   02-May-2002  14:28  5.00.2195.5722  45,328  Eventlog.dll
				

With this fix installed, you can implement an automatic backup process (by using a registry key) when the current event log cannot be extended. You can add a registry key for each event log to increase the time before the event log becomes full, or before the computer hangs. Note that the size of the event logs is still limited by the available resources on the computer (such as virtual memory and free disk space).

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To use the new automated backup behavior after you apply this hotfix, you must add registry keys. For example:

Keys:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EventLog\Security
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EventLog\Application
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EventLog\System
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EventLog\DNS Server

Value: AutoBackupLogFiles
Type: DWORD
Data value: Value not present or 0 (zero) equals turned off (the default). Any non-zero value equals turned on.

NOTE: You must restart the computer or clear the corresponding event log before the new behavior takes effect. If you are using the "Shut down system immediately if unable to log security audits" (CrashOnAuditFail) policy and if you do not clear the security log after you set the Security registry value to 1, the computer still hangs on an audit failure.

Description of the AutoBackupLogFiles registry entry

Using this entry causes the Event Log service to automatically clear a full event log and to back up the log file. On computers with the "CrashOnAuditFail" policy turned on, the computer continues to log events (instead of hanging because of an audit failure) if the current log file can be backed up automatically. By default, event logs are stored in the %SystemRoot%\System32\Config folder. If you turn on this registry value, a full log file is automatically backed up in the %SystemRoot%\System32\Config folder, the log file is cleared, and event logging resumes.

If you turn on this registry value, you must make sure to move or delete the backup log files from the System volume. If you do not, the volume may become full. Microsoft recommends that you implement a manual or automated procedure to move or delete the backup log files to prevent the backup log files from consuming all of the space on the System volume. If you turn on this registry value, take immediate action if you receive a "Disk full" message.

When a log file is successfully backed up, event 524 is logged with a source of "eventlog" in the Security event log file. The event is similar to:

The Security log file was saved as Security-2002-02-05-22-48-40-042.evt because the current log file is full.

The name of the backup file is a concatenation of the log file name and the date and time (in coordinated universal time, or UTC). The name has this format:

Log name-year-month-day-hour-minute-seconds-millisecond.evt

The backup log file name will look similar to this:

Logname-YYYY-MM-DD-HH-MM-SSS-mmm.evt

Turning this registry value on or off affects all of the log files. The change takes effect after you restart the computer, or clear any event log.

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server product

For additional information about how to install multiple hotfixes with only one reboot, click the following article number to view the article in the Microsoft Knowledge Base:

296861 How to install multiple Windows updates or hotfixes with only one reboot


Modification Type:MinorLast Reviewed:10/7/2005
Keywords:kbHotfixServer kbQFE kbDirServices kbWin2kSP4fix kbbug kbfix kbQFE kbWin2000preSP4Fix KB312571