Visual Studio Debugger stops responding after you install a post-Beta 2 build (312115)



The information in this article applies to:

  • Microsoft Visual Studio 2005 Standard Edition
  • Microsoft Visual Studio 2005 Professional Edition
  • Microsoft Visual Studio .NET (2003), Professional Edition
  • Microsoft Visual Studio .NET (2002), Professional Edition

This article was previously published under Q312115

SYMPTOMS

After you upgrade from the Beta 2 (or earlier) version of Visual Studio .NET to a later version, the Visual Studio 2005 or Visual Studio .NET Debugger may stop responding (hang). This behavior is caused by a bug in the uninstall program, and it occurs after you upgrade in the following manner:
  1. You install Beta 2 or an earlier version of Visual Studio .NET.
  2. You uninstall the Beta 2-or-earlier version.
  3. You install a later build of Visual Studio 2005 or Visual Studio .NET (PDC, RC0, RC1, RTM, and so on).

CAUSE

This behavior is caused by a flaw in the uninstall program. The entry for .NET Framework Support Service is not removed from the list of services during uninstall. This service might also appear as COM+ Runtime Service or Core RTVC. This service is disabled by default in the PDC and some later builds, causing the debugger to stop responding.

Not all of the usage scenarios that cause the debugger to stop responding are known. One known scenario is when you run the debugger through Terminal Services.

RESOLUTION

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

To resolve this issue, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click the Administrative Tools icon, and then double-click the Services icon.
  3. In the Services window, right-click the service name, .NET Framework Support Service, and then click Properties.
  4. On the General tab, select Disabled from the Startup Type list box, and then click OK.
  5. If the Service Status is currently running, stop it. To do this, follow these steps:
    1. Right-click the service name, .NET Framework Support Service, and then click Properties.
    2. On the General tab, in the drop-down list box for Startup Type, click to select Disabled.
    3. Click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Specifically, this behavior is related to the uninstall program for the .NET Framework software developer's kit (SDK). If you update only the Framework SDK version, you may still experience this issue.

Modification Type:MajorLast Reviewed:2/21/2006
Keywords:kbvs2005applies kbvs2005swept kbprb kbreadme KB312115