FIX: Analysis Manager Disappears When You Save a Role or Validate Security During Restore (311873)
The information in this article applies to:
- Microsoft SQL Server 2000 Analysis Services
This article was previously published under Q311873
BUG #: 12691 (plato7x)
SYMPTOMS
The Analysis Manager console disappears when you save an edited cube role or during the "Validating Security" step of a restore archive process.
If the problem occurs during role editing, the changes you made to the role do not save. If the problem occurs when you restore a database archive, the archive appears restored when you restart the Analysis Manager.
CAUSE
When Analysis Services saves changes to restrictions for a role or restores a role from a database archive, it attempts to validate all roles and their defined restrictions. If an error occurs, an error message displays that indicates the role name, the dimension where the restriction is defined and the multidimensional (MDX) expression that caused the error. The error message can hold up to 2048 characters. In cases where the combined size of the error message and the MDX expression that you use to define the restrictions for the role is larger than the 2048 character limit, Analysis Manager shuts down.
RESOLUTIONA supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next SQL Server service pack that contains this hotfix. To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix should have the following file attributes or later:
Date Time Version Size File name
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10/30/2001 04:07 PM 8.0.463.0 2,007,632 KB Msolap80.dll
10/30/2001 04:02 PM 8.0.463.0 213,069 KB Msolap80.rll
10/30/2001 04:07 PM 8.0.463.0 1,004,096 KB Msmdgd80.dll
10/30/2001 04:07 PM 8.0.463.0 213,572 KB Msmdcb80.dll
NOTE: Due to file dependencies, the most recent hotfix or feature that contains the preceding files may also contain additional files. STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 10/5/2005 |
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Keywords: | kbbug kbfix kbQFE KB311873 |
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