Color Management Settings for Terminal Server Client Automatically-Created Printer Are Not Persistent (311870)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2

This article was previously published under Q311870

SYMPTOMS

When an administrator adjusts the color management settings, for example, by setting a color profile for a Terminal Server client user's automatically-created printer, the settings may not be persistent. When the user logs off and connects again, the color management settings may be gone, and may be set to the default settings.

CAUSE

During logon, the restoration process does not work, and an access denied error message may be generated because color profiles can only be restored by an administrator or by the system, and the restoration process is completed while the user is impersonated.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

The English version of this fix should have the following file attributes or later:
   Date       Time   Version        Size     File name
   ------------------------------------------------------
   18-Jan-02  11:31  5.0.2195.4857  381,200  Printui.dll
   18-Jan-02  11:31  5.0.2195.4857   54,032  Wlnotify.dll
				

NOTE: When the administrator adjusts the settings, these settings take effect immediately, but it may take over five minutes for the client to receive and store the changes.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:

296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot

For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:

249149 Installing Microsoft Windows 2000 and Windows 2000 Hotfixes


Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbenv kbfix kbTermServ kbui kbWin2000PreSP3Fix kbWin2000sp3fix KB311870