PRB: Restoring a metabase backup made before the installation of an existing IIS Service disables functionality (311625)



The information in this article applies to:

  • Microsoft Internet Information Services 5.0
  • Microsoft Internet Information Services version 6.0

This article was previously published under Q311625

SYMPTOMS

If you restore a metabase backup that was made before you installed the SMTP, FTP, NNTP, or WWW Web services, that service does not appear in Internet Information Services Manager (ISM). Although the service may still be listed under Services, you receive an error message when you try to start that service. The error message that you receive depends on how you start the service.

The following example uses the FTP service:
  • When you start the service by using the Services applet, you receive the following error message:
    Could not start the FTP Publishing Service service on Local Computer.

    Error 3: The system could not find the path specified.
  • When you start the service from a command prompt by using net start msftpsvc, you receive the following error message::
    A system error has occurred. System error 3 has occurred. The system cannot find the path specified.
The following errors may appear in the system event log:Event Type: Error
Event Source: MSFTPSVC
Event ID: 116
The service metabase path '/LM/MSFTPSVC/' could not be opened. The data is the error code.Event Type: Error
Source: Service Control Manager
Event ID: 7023
The FTP Publishing Service service terminated with the following error:
The system cannot find the path specified.

CAUSE

The backup copy of the metabase has no information for that service because the service was not installed at the time that the backup was made. When the backup is restored, the metabase is completely overwritten with the older information, and the service information is no longer present.

RESOLUTION

If you have a backup of the metabase that was made after the service was installed, restore the metabase from that backup copy. If no other backup exists, use Add or Remove Programs in Control Panel to remove and reinstall the service.

STATUS

This behavior is by design.

Modification Type:MinorLast Reviewed:2/14/2004
Keywords:kbprb KB311625 kbAudITPRO