Mailbox Manager may miss its schedule if the server is under load (311497)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server

This article was previously published under Q311497

SYMPTOMS

If you set the Mailbox Manager schedule to one 15-minute block, it is possible that the process will not run if the server is under load.

CAUSE

The Mailbox Manager process is designed to wake and check the schedule every 15 minutes. The process (clean mailbox) may wake an instant before the scheduled block of time. If this occurs, it would see that it is not yet time to process mailboxes, and go back to sleep. If the wake-up time is delayed by the operating system so that the next schedule check is an instant after the 15 minute block, mailboxes would not be cleaned.

WORKAROUND

To work around this behavior, set two 15-minute time blocks (back-to-back) in the schedule. This greatly increases the chances that the Mailbox Manager process will run. However, if the server is not under load, or does not have very much to do on that cycle, it may run two cleanup processes rather than one.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbbug kbnofix KB311497