BUG: The Error Message "Query Failed" Is Displayed When You Add a UserType Dimension to a Pivot Table (311485)



The information in this article applies to:

  • Microsoft Commerce Server 2000

This article was previously published under Q311485

SYMPTOMS

You may experience the following problems in Commerce Server:
  • The Data Transformation Services (DTS) Report Preparation task fails.
  • The pivot displays a "Query Failed" message when you drop the UserType dimension into the pivot.
  • The Campaign cube fails to process and the following error messages are logged in Event Viewer:
    Server out of memory.

    Failed to reallocate space.

CAUSE

These problems occur because a considerable amount of memory resources are allocated when the online analytical processing (OLAP) Campaign cube is being processed with the UserType dimension present.

RESOLUTION

These performance problems were resolved in Commerce Server Service Pack 1 (SP1); by default, the UserType dimension is not included in the Campaign cube. If you need to include the UserType dimension in the Campaign cube, use the following steps to enable processing of this dimension:
  1. Start Analysis Manager.
  2. Open the OLAP database for your Data Warehouse.
  3. Edit the Campaign cube.
  4. Select the UserType dimension.
  5. Change the Enabled property to True.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Steps to Reproduce the Behavior

  1. Open the Campaign Event Summary report.
  2. In the pivot list, click UserType, and then use a drag-and-drop operation to move it into the row or the column dimension area of the pivot table.

Modification Type:MajorLast Reviewed:10/17/2002
Keywords:kbbug KB311485