SMS: Missing Advertisement Status Messages (311212)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0
  • Microsoft Systems Management Server 2.0 SP1
  • Microsoft Systems Management Server 2.0 SP2
  • Microsoft Systems Management Server 2.0 SP3
  • Microsoft Systems Management Server 2.0 SP4

This article was previously published under Q311212

SYMPTOMS

Some advertisement status messages from client computers may not be returned to the SMS database and Status Manager may sporadically delete status message files and log errors stating that the files are in use and damaged. If you experience this problem, you can view the log entries that are similar to the following log entries in the Statmgr.log file:
ERROR: Could not open file
"C:\SMS\inboxes\statmgr.box\statmsgs\IBNQWXY4.SVF", the file is assumed to be corrupt. The operating system reported error 5: Access is denied. Deleted corrupt file "C:\SMS\inboxes\statmgr.box\statmsgs\IBNQWXY4.SVF".

-or-

ERROR: Could not open file
"C:\SMS\inboxes\statmgr.box\statmsgs\IUSH4YZ5.SVF", the file is assumed to be corrupt. The operating system reported error 32: The process cannot access the file because it is being used by another process. ERROR: Could not delete corrupt file "C:\SMS\inboxes\statmgr.box\statmsgs\IUSH4YZ5.SVF". The operating system reported error 32: The process cannot access the file because it is being used by another process.
Similar problems with other components may also occur. View the following Microsoft Knowledge Base article for information about similar symptoms when you use the Software Inventory Processor component:

303279 SMS: Software Inventory Processor Has a Critical Status

CAUSE

This problem may occur if Inbox Manager Assistant (SMS_INBOX_MANAGER_ASSISTANT) copies a file from a Client Access Point (CAP) to the site server because Inbox Manager Assistant uses the file's original file extension. If the file is large or if the CAP-to-site server link is slow, the receiving SMS component (for example, Status Manager) may start processing the file before it is completely copied.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Systems Management Server 2.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

288239How to Obtain the Latest Systems Management Server 2.0 Service Pack

Hotfix Information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Systems Management Server (SMS) service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The hotfix that was originally provided for the problem that is described in this Microsoft Knowledge Base article has been superceded. To resolve the problem described in this article, install the hotfix for 810298. For additional information about how to install the hotfix for 810298, click the following article number to view the article in the Microsoft Knowledge Base:

810298 SMS: .tmp Files Accumulate in the Ccr.box Folder on the SMS Site Server

After you apply this hotfix, Inbox Manager Assistant copies every file from a CAP to the appropriate site server Inbox by using a .tmp file extension. After the file is copied to the Inbox, it is renamed with the correct file extension, which signals the receiving SMS component to process the file.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Systems Management Server 2.0 Service Pack 5.

MORE INFORMATION

The fix that is discussed in this article also resolves the problem that is discussed in the following Microsoft Knowledge Base article:

303279 SMS: Software Inventory Processor Has a Critical Status


Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbHotfixServer kbQFE kbSMS200preSP5fix kbMiscTools kbBug kbfix KB311212