"Invalid Page Fault in Module" Error Message When You Click Properties on Shortcut Menu (311180)



The information in this article applies to:

  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98
  • Microsoft Windows 95

This article was previously published under Q311180
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you right-click a file and then click Properties on the shortcut menu that appears, you may receive an error message similar to the following:
Explorer caused an invalid page fault in module <UNKNOWN> at 0000:00000000
-or-

When you start Windows, you may receive an error message similar to the following:
Unable to load the Dynamic Link Library: Novellnp.dll

One of the library files needed to run this application cannot be found.

Some or all of the following feature is not available:

Novell_Netware

CAUSE

This behavior can occur if your installation of the Novell Client32 client for Novell networks is damaged.

This behavior can also occur if the registry entries for the Novell Client32 program are not removed when you uninstall this program.

RESOLUTION

To resolve this issue, follow these steps.

Step 1: Edit the Registry

Delete the reference to the Novell Netware Provider from the Windows registry. To do this, follow these steps.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Start Windows in Safe mode.For additional information about starting Windows in Safe mode, click the article number below to view the article in the Microsoft Knowledge Base:

    180902 How to Start a Windows-Based Computer in Safe Mode

  2. Click Start, and then click Run.
  3. In the Open box, type regedit, and then click OK.
  4. In Registry Editor, expand the following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NOVELLNP

  5. On the Registry menu, click Export Registry File.
  6. In the File name box, type Novellnp, and then click Save.
  7. On the Edit menu, click Delete.
  8. In the Confirm Key Delete dialog box, click Yes.
  9. Quit Registry Editor.
  10. Restart the computer in Safe mode.

Step 2: Rename the Clnwin32.dll File

To rename the Clnwin32.dll file, follow these steps:
  1. With Windows running in Safe mode, click Start, point to Find, and then click Files or Folders.
  2. In the Named box, type clnwin32.dll.
  3. In the Look in list, click My Computer, and then click Find Now.
  4. In the list of found items, right-click Clnwin32.dll, and then click Rename on the shortcut menu that appears.
  5. Rename Clnwin32.dll as Clnwin32.old, and then press ENTER.
  6. On the File menu, click Close.
  7. Restart the computer in Normal mode.

    NOTE: If you want to use the Novell Client32 client program, you must reinstall it.

MORE INFORMATION

For additional information about troubleshooting Windows startup problems, click the article number below to view the article in the Microsoft Knowledge Base:

192926 How to Perform Clean-Boot Troubleshooting for Windows 98

For additional information about the Novell Client program, browse to the following Novell Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:12/20/2004
Keywords:kb3rdparty kberrmsg kbInvalidPageFault kbprb KB311180