You receive a "Word cannot complete the save due to a file permission error" error message when you save a document on Index Server (311153)



The information in this article applies to:

  • Microsoft Word 2002

This article was previously published under Q311153

SYMPTOMS

If you try to save a Microsoft Word document that was opened from a Microsoft Windows NT 4.0 SP6 Server that is running Index Server, you may receive the following error message:
Word cannot complete the save due to a file permission error
If you try to delete the files from the Index Server, you receive the following error message:
Access Denied

CAUSE

This problem can occur when the Index Server has catalogued the Word documents.

RESOLUTION

To resolve this problem, obtain the latest service pack for Microsoft Office XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

307841 OFFXP: How to Obtain the Latest Office XP Service Pack

The English version of this fix should have the following file attributes or later:
   Date           Time   Version       Size       File name
   --------------------------------------------------------------
   26-Mar-2002    00:56  n/a               2,962  Readme.txt
   26-Mar-2002    00:38  n/a           4,223,912  SHARED.msp
   26-Mar-2002    01:59  n/a           6,883,568  SHARED_Admin.msp
				
After the hotfix is installed, the following files will have the listed attributes or later:
   Date          Time   Version         Size       File name
   ----------------------------------------------------------
   22-Mar-2002   15:56  10.0.3919.0     9,996,616  MSO.DLL
				

WORKAROUND

To work around this problem, use any of the following methods.

Method 1

Turn off the Index Server. To do this, follow these steps:
  1. Click Start and then click Run.
  2. In the Open box, type ciadmin.msc and then click OK.
  3. Click Index Server on Local Machine.
  4. On the Action menu, click Stop.

Method 2

NOTE: This method can be used as a temporary workaround but it does not always resolve the problem.

Update the Index Server cache. To do this, follow these steps:
  1. Click Start and then click Run.
  2. In the Open box, type ciadmin.msc and then click OK.
  3. Expand Index Server on Local Machine.
  4. Expand the Index Scope that you want.
  5. Click the Properties folder.
  6. On the Action menu, click Commit Changes.
  7. In the Update Cache dialog box, click Yes .

Method 3

On the File menu in Word 2002, click Save As and then save the document as Word97-2002&6.0/95 RTF.

Method 4

Upgrade to Microsoft Windows 2000 Server. This problem does not occur with the Windows 2000 Index Server option.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Office XP Service Pack 2 (SP-2).

Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbsavefile kbbug kbfix kbOfficeXPPreSP2fix kbOfficeXPsp2fix KB311153