Time-Out Error Message When You Attempt to Connect to the Web Through Internet Connection Sharing (311070)



The information in this article applies to:

  • Microsoft Windows XP 64-Bit Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q311070
For a Microsoft Windows Millennium Edition version of this article, see 229890.

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you connect to the Web by using Internet Connection Sharing (ICS), you may receive a time out error message. For example, the Web page may display the following error message
We can't find "xxx.xx.xxx.xx"
where "xxx.xx.xxx.xx" is the IP address or URL of the Web page that you are attempting to log on to.

CAUSE

This behavior can occur if an Internet connection takes longer to complete than the time-out period specified in the client's request. For example, if the phone line is busy, an Internet connection cannot be established and, therefore, the initial Internet request times out.

RESOLUTION

To resolve this issue, use any of the following methods, as appropriate to your circumstances:
  • Re-send the Internet request. To do this, press F5 in Microsoft Internet Explorer.
  • Manually establish the connection to the Internet by using the ICS host computer.
  • Add the NameSvrQueryTimeout string value to the following registry key:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netbt\Parameters

    To do this, follow these steps.

    WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

    1. Start Registry Editor (Regedt32.exe).
    2. Locate and then select the following registry key:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netbt\Parameters

    3. On the Edit menu, point to New, and then click String Value.
    4. Name the string value as follows:

      NameSvrQueryTimeout

    5. Double-click NameSvrQueryTimeout, and then in the Value data field, type 10000 to set a timeout value of 10 seconds to allow the host computer to finish connecting to the Internet.
    6. Adjust the number as needed (10000 = 10 seconds).
    7. Quit Registry Editor.

MORE INFORMATION

The amount of time an Internet program takes to time out for a request sent to the Internet depends on a number of factors, including the program's design. When you first start ICS, it sends a Dynamic Host Configuration Protocol (DHCP) Discover packet to verify that it is the only DHCP allocator on the local area network (LAN). This prevents the ICS host from forwarding any Internet requests to the Internet for about 60 seconds after the ICS host has restarted and logged on to Windows.

For additional information about TCP/IP, click the article numbers below to view the articles in the Microsoft Knowledge Base:

102908 How to Troubleshoot TCP/IP Connectivity with Windows

113342 How to Test a TCP/IP Router or Multihomed Host

120642 TCP/IP & NBT Configuration Parameters for Windows NT, Windows 2000, and Windows XP

170359 How to Modify the TCP/IP Maximum Retransmission Timeout

224829 Description of Windows 2000 TCP Features


Modification Type:MajorLast Reviewed:8/6/2002
Keywords:kbDialUp kberrmsg kbFAQ kbprb KB311070