BUG: ActiveSync Stops Responding When You Try to Stop Synchronization (310924)



The information in this article applies to:

  • Microsoft ActiveSync 3.6
  • Microsoft ActiveSync 3.5
  • Microsoft ActiveSync 3.1
  • Microsoft ActiveSync 3.0

This article was previously published under Q310924

SYMPTOMS

When you synchronize very large objects between the device and your desktop, Microsoft ActiveSync may stop responding (hang) when you attempt to stop synchronization. The ActiveSync user interface shows the status as "Stopping..." and the green wheel continues to spin.

CAUSE

During the synchronization of large objects, the IReplObjHandler::GetPacket method may be called multiple times. If you decide to stop synchronization in between the first and last GetPacket calls, ActiveSync Manager does not send the Cancel packet to the device side. In other words, the behavior described in the "Symptoms" section of this article occurs when ActiveSync has been implemented to transfer a large object in multiple packets, and, during this transfer, you press Stop in the ActiveSync application.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

ActiveSync Manager continuously calls IReplObjHandler::GetPacket until RWRN_LAST_PACKET is returned by GetPacket.

If the size of your synchronization object is greater than the cbRecommend parameter of GetPacket, it is highly recommended that you send only the number of bytes advised by the cbRecommend parameter to the device, and then send the rest of the bytes in the next call to GetPacket.

GetPacket should return NOERROR if it has more data to send to the device.

Modification Type:MinorLast Reviewed:8/18/2005
Keywords:kbbug kbpending KB310924 kbAudDeveloper