PRB: Internal Server Error (500) Occurs upon Postback (310904)
The information in this article applies to:
- Microsoft Mobile Internet Toolkit (MMIT)
This article was previously published under Q310904 SYMPTOMS
When browsing a mobile Web Form page with the OmniSky browser on a Palm Vx, you may receive the following error message:
Internal Server Error (500)
CAUSE
This behavior occurs because the OmniSky browser on the Palm Vx does not support cookies. When the page is posted back to the server, the mobile runtime is expecting a cookie that contains the session ID. This session ID is used to identify a unique session on the Web server that contains the ViewState information. Because cookies are not available, data that is maintained in ViewState is lost and is not available upon post back.
RESOLUTION
To resolve this behavior, enable cookieless sessions in your mobile Web application. Cookieless sessions store the session ID in the URL of the page. When the page is posted back to the server, the mobile runtime can identify the unique session on the server.
To enable cookieless sessions, modify the Web.config file in your Web application. Within the Web.config file, set the cookieless attribute of the <sessionState> element to true:
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<system.web>
<sessionState cookieless="true" />
</system.web>
</configuration>
STATUSThis behavior is by design.
Modification Type: | Major | Last Reviewed: | 6/14/2002 |
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Keywords: | kbCookie kbDeviceSpecific kbDSupport kbHTMLDevice kbprb kbState KB310904 |
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