STOP Error When You Start Windows After You Connect a Scanner (310869)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q310869

SYMPTOMS

When you try to start Microsoft Windows XP after you use the parallel port to connect a Hewlett Packard (HP) ScanJet 4400 or 4470, the computer may stop responding during startup at a Critical Stop Error.

You may receive the following blue screen error message:
STOP: STOP 0x50 (0xfe9fb004, 0x00000000, 0xfdfbc695, 0x00000000) A fatal system error has occurred.

CAUSE

This issue occurs when HP scanners that do not have a Device ID ROM report an invalid Device ID string when they are queried for a Device ID. Because there is no validation of the device reported ID string length in the driver, the driver reads bytes from the device and overwrites kernel memory until the memory corruption causes the computer to stop responding.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to Obtain the Latest Windows XP Service Pack

The English version of this fix should have the following file attributes or later:
   Date         Time   Version             Size   File name
   --------------------------------------------------------------
   18-Oct-2001  10:14  5.1.2600.16       898,048  Kernel32.dll
				

WORKAROUND

To work around this issue, connect the scanner to the Universal Serial Bus (USB) port on the computer.

For additional information about how to install your HP ScanJet scanner, browse to the following Hewlett Packard Web site:

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows XP Service Pack 1.

MORE INFORMATION

For additional compatibility and support information for Hewlett Packard imaging devices used with Windows XP, browse to the following Hewlett Packard Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbOSWin2000fix kbWinXPsp1fix KB310869