How to troubleshoot error messages that you receive when you try to restore a backup file in Money (310858)



The information in this article applies to:

  • Microsoft Money Deluxe 2006
  • Microsoft Money Premium 2006
  • Microsoft Money Small Business 2006
  • Microsoft Money Standard 2006
  • Microsoft Money 2005 Deluxe
  • Microsoft Money 2005 Premium
  • Microsoft Money 2005 Small Business
  • Microsoft Money 2005 Standard
  • Microsoft Money 2004 Deluxe
  • Microsoft Money 2004 Premium
  • Microsoft Money 2004 Small Business
  • Microsoft Money 2004 Standard
  • Microsoft Money 2003 Deluxe
  • Microsoft Money 2003 Deluxe and Business
  • Microsoft Money 2003 Standard
  • Microsoft Money 2002
  • Microsoft Money Deluxe 2002
  • Microsoft Money 2002 Deluxe and Business Edition
  • Microsoft Money 2001
  • Microsoft Money 2000
  • Microsoft Money 99
  • Microsoft Money 2007 Deluxe
  • Microsoft Money 2007 Home & Business
  • Microsoft Money 2007 Premium

This article was previously published under Q310858

SYMPTOMS

When you try to restore the Microsoft Money data file from a backup file, you may receive an error message that is similar to one of the following:
Money cannot locate '<location of your Money data file>' or cannot open it, possibly because it is a read-only file or your disk drive is write protected.
'<location of your Money data file>' is corrupted or is not a Money data file. Make sure you are opening a file with an .mny extension.
Money cannot create a temporary file in C:\Windows\temp\
There is not enough disk space to create your Money data file in Temporary Files.
The Path Name Is Invalid

CAUSE

This issue may occur if any one of the following conditions is true:
  • The path that you are trying to restore your file to is no longer valid. Typically, this issue occurs after you upgrade the Microsoft Windows operating system to Microsoft Windows XP.
  • You are trying to restore a backup file that was created in a later version of Money than the version that is installed on the computer.
  • You are running out of free disk space on the hard disk.
  • Your backup medium is damaged.
  • Your backup Money data file is damaged.
  • You are trying to restore a Microsoft Money 2005 backup file into Microsoft Money 2006. The Money 2005 backup file does not have Microsoft Passport Network credentials (the e-mail address and password that you use to sign in to the Passport Network) or a password.
  • You are trying to restore or convert a data file from Money 98/99 to Money 2006 or later.

RESOLUTION

To resolve this issue, use the following methods in the order that they appear in.

Method 1: Verify the validity of the restore path

When you restore the Money data file, the path where you want to restore the file must be valid. To verify this, make sure that you are walking through the restore process correctly. For more information about how to restore a backup file in Money, click the following article number to view the article in the Microsoft Knowledge Base:

178850 How to restore a backup file in Microsoft Money

Method 2: Make sure that you are not trying to restore a backup file from a later version of Money

When you are using multiple versions of Microsoft Money, note that Money is not backward compatible. For example, if you are using Microsoft Money 2006 on one computer and Microsoft Money 2005 on another computer, you cannot open the Money 2006 backup file in Money 2005. However, you can open the Money 2005 file in Money 2006 program.

Method 3: Increase Hard Disk Free Space on Your Computer

  1. On the desktop, double-click My Computer.
  2. Right-click the disk that you want to restore the backup file to, and then click Properties.
  3. Note the amount of free disk space.
If the disk is almost full (very little free space), free some space. To do this, delete all Temporary files and Temporary Internet files, uninstall nonessential programs, and delete unnecessary data files.

For more information about how to free space on the hard disk, see the Microsoft Windows documentation.

If there is sufficient space on the hard disk to restore the backup file, but you are still cannot restore the backup file, go to Method 4.

Method 4: Copy file to the hard disk

  1. Double-click My Computer.
  2. Double-click your backup disk.
  3. Right-click the file, and then click Copy.
  4. On the standard toolbar of the My Computer window, click Back. The focus returns to My Computer.
  5. Double-click Local Disk (C:).
  6. Double-click My Documents.
  7. Click Edit, and then click Paste.
If you receive any error messages during this copy and paste scenario, you have damaged backup medium. There are few repair scenarios that you can use in this situation. See the Microsoft Windows documentation for more information about how to repair damaged disks. After your file is copied to the hard disk drive, follow the restore backup procedure again. If you continue to receive an error message, it is likely that your backup data file is damaged.

Method 5: Confirm that Money is working correctly

  1. Quit Money.
  2. Search your computer for the Sample.mny data file.
  3. Double-click the file to open it.
  4. Create a backup of the Sample.mny file, either to a disk or to a location on the hard disk drive.
  5. After the backup is complete, follow the process to restore the backup file.
If this process is successful, the Money product is working as expected. If you have another backup file that you can try to restore, that is recommended. If you do not have another backup data file, re-create the Money data file. If you also receive an error message when you try to restore the Sample.mny Money data file, your Money installation files may be damaged. For more information about how to remove and reinstall Money, click the following article number to view the article in the Microsoft Knowledge Base:

895866 How to remove and reinstall Microsoft Money

If you were trying to restore a Money 2005 backup file into Money 2006 and the Money 2005 backup file does not have Passport Network credentials or a password, use one of the following workarounds:
  • Find the Money 2005 .mny file instead of the backup file. Open the Money 2005 .mny file in Money 2006.
  • Restore the Money 2005 backup file in Money 2005, and then open that restored Money 2005 .mny file in Money 2006 or add Passport Network credentials or a password to the Money 2005 file. Create a new Money 2005 backup file, and then restore that backup file in Money 2006.

    Note To create a password for the Money 2005 file, click File, and then click Password Manager.

Method 6: Converting files from Money 98/99 to 2006 or later

If you are trying to convert a data file from Money 98/99 to Money 2006 or later you will receive one of the messages listed above. This issue occurs because of the enhanced security features in Money 2006 or later. Money 2006 or later does not let you directly convert a Money 99 data file or a Money 98 data file to Money 2006. For more information about converting data from Money 98 or 99 to 2006, click the following article number to view the article in the Microsoft Knowledge Base:

913108 You cannot convert Money 98 or Money 99 data files into Money 2006 data files

MORE INFORMATION

To minimize loss of data because of a corrupted backup file, we recommend that you back up data to at least two different backup mediums. You can perform each backup two times, one time to each backup medium. For example, use a floppy disk and a Zip drive, or other backup files by alternating the backup medium every time that you back up data.

Modification Type:MinorLast Reviewed:7/14/2006
Keywords:kberrmsg kbprb KB310858