Your Computer May Stop Responding After You Remove Either a CD-ROM Drive or a DVD Drive from the Drive Bay (310664)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q310664

SYMPTOMS

You computer may stop responding (hang) when you attempt to hot detach either a CD-ROM or a DVD drive from the drive bay. Typically, you hot detach the drive by either clicking the Safely Remove Hardware icon in the status area of the taskbar or by using the device bay unlock lever.

Some computers may not support hot detaching the drive and may enter Standby mode automatically when you remove the device. If you resume the computer from Standby mode without removing the drive, the computer may hang until you remove the drive from the drive bay.

CAUSE

This problem occurs if you select UltraDMA (Ultra direct memory access) mode for either a CD-ROM drive or a DVD drive, if the drive is in the drive bay during a hot detach procedure, and if you do not reprogram the drive for the correct transfer mode. This leaves the drive and the controller in an "out of synchronization" condition; the Mode Sense command that is issued to the drive is lost, which causes the computer to hang while waiting for a response.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to Obtain the Latest Windows XP Service Pack

The English-language version of this fix should have the following file attributes or later:
   Date         Time   Version      Size     File name  Platform
   -------------------------------------------------------------
   02-Nov-2001  19:11  5.1.2600.18  86,784   Atapi.sys  Intel
   02-Nov-2001  19:11  5.1.2600.18  304,128  Atapi.sys  64-bit
				

WORKAROUND

To resolve this problem, select PIO mode in your computer basic input/output system (BIOS).

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows XP Service Pack 1.

Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbHardware kbOSWin2000fix kbWinXPsp1fix KB310664