Troubleshooting invalid CD key error message during Windows XP setup (310637)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q310637

SYMPTOMS

When you enter your product key for Microsoft Windows XP during installation, you may receive an error message that is similar to one of the following:
  • The CD Key which you entered is invalid. Please try again.
  • The Product Key used to install Windows is invalid. Please contact your system administrator or retailer immediately to obtain a valid Product Key. You may also contact Microsoft Corporation's Anti-Piracy Team by emailing piracy@microsoft.com if you think you have purchased pirated Microsoft software. Please be assured that any personal information you send to the Microsoft Anti-Piracy Team will be kept in strict confidence.

CAUSE

This issue can occur if one or more of the following conditions are true:
  • You did not enter the proper product key.
  • Anti-virus software is running during Setup.
  • The installation compact disc (CD) is damaged.
  • You are installing Windows XP Service Pack 1 or Service Pack 2 to a second partition on your hard disk.
  • You started the Windows XP service pack update Setup program from within Windows XP.

RESOLUTION

To troubleshoot this issue, perform the following steps in the order that they are listed, testing between each step to determine if the issue is resolved:
  1. Verify that the product key is correctly entered into the Product Key boxes.

    Note If you are unable to locate your product key, or if your product key label is damaged, contact Microsoft Product Support Services. For more information, please visit the following Microsoft Web site:

    http://support.microsoft.com/contactus/?ws=support
  2. Verify that your anti-virus software is not running when you run Windows Setup. For information about how to disable your anti-virus software, view the documentation that is included with your anti-virus program, or contact the manufacturer of your anti-virus program.
  3. Disable the anti-virus settings in your computer's Basic Input/Output System (BIOS) before you start Setup. For more information, view the documentation included with your motherboard or computer, or contact the manufacturer of your motherboard or computer.
  4. Verify that your installation media is not damaged. If it is, replace it.
  5. Verify that the computer's system date is correct. For information about how to check the date in your computer's CMOS settings, view the documentation included with your motherboard or computer, or contact the manufacturer of your motherboard or computer.
  6. Try starting Windows without loading extra drivers and programs. This provides as clean an installation environment as possible. After you "clean-boot" your computer, rerun Setup.

    For additional information about how to start Windows with a minimal set of drivers, click the following article numbers to view the articles in the Microsoft Knowledge Base:

    192926 How to perform clean-boot troubleshooting for Windows 98

    267288 How to perform a clean boot in Windows Millennium Edition

    310353 How to perform a clean boot in Windows XP

  7. Install the operating system from a command prompt instead of from within the Windows environment.
  8. Copy the installation files from the CD to the hard disk, and then run Setup from the hard disk.
  9. If you are upgrading from Microsoft Windows 98 or Microsoft Windows Millennium Edition (Me), use the ScanDisk tool (Scandskw.exe) to check your hard disk for errors. To do this, click Start, point to Programs, point to Accessories, point to System Tools, and then click ScanDisk.

    For additional information about how to run Setup from a command prompt, click the following article number to view the article in the Microsoft Knowledge Base:

    307848 How to start Setup from MS-DOS in Windows XP

  10. Use the number keys on the keyboard instead of the numeric keypad to type the product key.

    When you install an international version of Windows, Setup may use the US keyboard layout rather than the correct international keyboard layout. For example, letters such as Z and Y that are in one position on the German keyboard are in a different position on the US keyboard. In this case, type the German Z where the product ID has a Y.

MORE INFORMATION

For additional information about the Scandisk tool in Windows 98 and Windows Me, click the following article number to view the article in the Microsoft Knowledge Base:

186365 Description of ScanDisk for Windows (Scandskw.exe) in Windows 98/Me

For information about how to contact third-party software and hardware vendors, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z

For additional information about how to install Windows XP, click the following article numbers to view the articles in the Microsoft Knowledge Base:

286647 Windows XP Read1st.txt File Contents

306824 Release notes for Windows XP Setup contained in the Home.txt file

286463 Release notes for Windows XP Setup contained in the Pro.txt file

For additional information about how to set up a dual-boot or multi-boot system with Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

153762 How to set up dual boot after you install Windows

For additional information about how to troubleshoot Setup issues in Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

310064 How to troubleshoot Windows XP problems during installation when you upgrade from Windows 98 or Windows Me

WORKAROUND

To work around the issue of installing a service pack for Windows XP to a second partition on your hard disk or another hard disk, start your computer from the Windows XP service pack Setup CD, and then install the Windows XP update to the other partition on your hard disk.

Note To start your computer from the Windows XP service pack Setup CD, your computer must be configured to start from the CD-ROM drive or the DVD-ROM drive. Sometimes, you may have to modify your computer's BIOS settings to set this configuration. For information about how to configure your computer to start from the CD-ROM drive or the DVD-ROM drive, see the documentation that is included with your computer, or contact the computer manufacturer.

Modification Type:MajorLast Reviewed:9/20/2005
Keywords:kbprb KB310637