"This program has encountered an error" error message when you try to start Streets & Trips or MapPoint (310596)



The information in this article applies to:

  • Microsoft Autoroute 2006 English (United Kingdom)
  • Microsoft MapPoint 2006 Standard Edition
  • Microsoft MapPoint 2004 North American Maps
  • Microsoft MapPoint 2002
  • the operating system: Microsoft Windows NT 4.0
  • the operating system: Microsoft Windows XP
  • the operating system: Microsoft Windows 2000
  • Microsoft Streets & Trips 2006
  • Microsoft Streets & Trips 2005
  • Microsoft Streets & Trips 2004
  • Microsoft Streets & Trips 2002 1.0
  • Microsoft Streets and Trips 2003
  • the operating system: Microsoft Windows NT 4.0

This article was previously published under Q310596

SYMPTOMS

When you try to start Microsoft Streets & Trips or Microsoft MapPoint, you may receive an error message that is similar to the following:
This program has encountered an error and will close.
When you click the To see what data this error report contains click here link, the following information appears:
Error Details

This application is unable to continue running due to an internal error. (6-40028--1073741819)

Error Signature

AppName: Streets.exe AppVer: 9.0.16.2001 ModName: moduleName
ModVersion: 0.2.0.0 Offset:0001bd57
where moduleName is one of the following module names:

PRNUI301.DLL
HPOUIP07.DLL
HPZNTP05.DLL
RIC616U.DLL
RIC516U.DLL
NTDLL.DLL
HPZPM309.dll

When you try to use the Find feature in Streets & Trips or in MapPoint, you may receive an error message that is similar to the following:
This program has encountered an error and will close.
When you click the To see what data this error report contains click here link, you receive the following error message details:
Error Details

This application is unable to continue running due to an internal error. (6-40028--1073741680)

CAUSE

This issue may occur if one of the following conditions is true:
  • You have a Canon Bubble Jet printer, a Canon MultiPass multifunction device printer, or a Canon c530-series printer installed.
  • You have a Hewlett Packard (HP) printer installed from the network, and that network printer is not turned on or is not connected to the network.
  • You have the FaxTalk Communicator program installed, and the default printer is configured to use the Ricoh AP 1600, PCL5, or PCL6 printer driver.
This issue is caused by an incompatible printer driver (or drivers) or, for an HP network printer, by unsuccessful communication with the network printer. This issue has also been reported to occur with other fax programs.

RESOLUTION

To resolve this issue, use one or both of the following methods, depending on your situation.

Method 1: Reconnect the network printer

If you have a networked HP printer installed, start the computer that shares the printer or reconnect the printer to the network. Or, configure a default printer other than the networked HP printer.

Note In some cases, you must remove the printer to resolve this issue.

Method 2: Update the printer or fax drivers

Update the printer or fax drivers to the latest versions. Contact the printer manufacturer or fax program manufacturer to obtain the latest device drivers. For information about how to contact hardware manufacturers and program vendors, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z

WORKAROUND

To work around this issue, remove the printer. To remove a printer, follow these steps:

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Log on to the computer as Administrator.
  2. Click Start, point to Settings, and then click Printers.
  3. Right-click the printer that you want to remove, and then click Delete.
  4. Click Yes to confirm the removal of the printer.
  5. Rename the Prnui301.dll file. To do this, follow these steps:
    1. Click Start, point to Search, and then click For Files or Folders.
    2. In the Search for files or folders named box, type prnui301.dll.
    3. In the Look in list, click My Computer, and then click Search Now.
    4. In the Search Results pane, right-click Prnui301.dll, and then click Rename.
    5. Type prnui301.old, and then press ENTER.
  6. Restart the computer.

MORE INFORMATION

For more information about FaxTalk Communicator, visit the following FaxTalk Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:4/26/2006
Keywords:kberrmsg kbprb KB310596