PRB: Upgrade Wizard Fails with "Logins ID unable to open registry on the target computer." Error Message (310542)



The information in this article applies to:

  • Microsoft SQL Server 2000 (all editions), when used with:
    • the operating system: Microsoft Windows 2000
  • Microsoft SQL Server 7.0 Service Pack 3, when used with:
    • the operating system: Microsoft Windows 2000

This article was previously published under Q310542

SYMPTOMS

If you perform an in-place or "one computer" upgrade from Microsoft SQL Server 6.5 to SQL Server 7.0 or SQL Server 2000 on a Microsoft Windows 2000-based computer, the Upgrade Wizard may fail with the following error message:
The Upgrade wizard is failing to export the logins from SQL Server 6.5. 'Logins ID unable to open registry on the target computer.'

CAUSE

The Remote Registry Service is not running.

In order for the SQL Upgrade Wizard to access the registry keys for both versions of SQL Server, the Remote Registry Service must be running.

WORKAROUND

Start the Remote Registry Service, and then continue the upgrade process.

Modification Type:MinorLast Reviewed:7/15/2004
Keywords:kbpending kbprb KB310542