"Drive's Contents Have Changed: Restarting" Message When You Use Disk Defragmenter (310541)



The information in this article applies to:

  • Microsoft Windows XP 64-Bit Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q310541

SYMPTOMS

When you use the Disk Defragmenter tool to defragment your hard disk, you may receive the following message:
Drive's Contents Have Changed: Restarting...

CAUSE

This issue can occur if a program (such as an antivirus program or a screen saver) is running on the drive when the Disk Defragmenter tool is running.

RESOLUTION

To work around this issue, use one of the following methods.

NOTE: To analyze or defragment a volume you must logon using an account with administrator privileges.

Clean Boot the Computer

A "clean" boot is a method of reducing problems that may occur because of your computer's environment. Many problems that may occur when you run Windows or other programs can occur because there are conflicting drivers, terminate-and-stay-resident programs (TSRs), or other settings that load when you start your computer. Windows XP includes a System Configuration Utility tool (Msconfig.exe) to make performing a clean boot easier.

For additional information about clean booting in Windows XP, click the article number below to view the article in the Microsoft Knowledge Base:

310353 How to Perform a Clean Boot in Windows XP

Use Safe Mode

Instead of performing a clean boot, you may want to restart your computer in Safe mode, and then start the Disk Defragmenter tool. After you run Disk Defragmenter, restart your computer.

To start the computer in safe mode:
  1. Click Start, click Shut Down, and then, in the drop-down list, click Shut down.
  2. In the Shut Down Windows dialog box, click Restart, and then click OK.
  3. When you see the message Please select the operating system to start, press F8.
  4. Use the arrow keys to highlight the appropriate safe mode option, and then press ENTER.
  5. If you have a dual-boot or multiple-boot system, choose the installation that you need to access using the arrow keys, and then press ENTER.

MORE INFORMATION

For additional information about how to troubleshoot issues with Disk Defragmenter, click the article number below to view the article in the Microsoft Knowledge Base:

305781 HOW TO: Analyze and Defragment a Windows XP Disk

227463 Disk Defragmenter Limitations in Windows 2000 and Windows XP

231176 Running Windows Disk Defragmenter Requires Administrator Privileges


Modification Type:MajorLast Reviewed:5/9/2002
Keywords:kbDefrag kberrmsg kbprb KB310541