SMS: Client May Not Accelerate When You Uninstall the Remote Control Feature (310508)
The information in this article applies to:
- Microsoft Systems Management Server 2.0
This article was previously published under Q310508 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you uninstall and then reinstall the Systems Management Server (SMS) 2.0 Remote Control feature on either a Microsoft Windows 2000-based or Microsoft Windows XP-based client computer, the clients may not be accelerated. You can determine that this is the problem that you are experiencing if you click Show Status in the Remote Control tool in Control Panel.
CAUSE
This problem occurs because the SMS Remote Control Uninstall program (Rcunist.exe), changes the Start value from 3 to 4 in the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Idisw2km
When this occurs, the Microsoft SMS Mirror driver (Idisw2km) is disabled. When you reinstall the Remote Control feature, Windows detects that Idisw2km is installed but does not verify that it is disabled.
WORKAROUNDWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk. To resolve this problem, obtain the latest service pack for Systems Management Server version 2.0. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
288239 SMS: How to Obtain the Latest Systems Management Server 2.0 Service Pack
To work around this problem:
- Start Registry Editor (Regedt32.exe).
- Locate and click the Start value in the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Idisw2km - On the Edit menu, click DWORD, type 3, and then click OK.
- Quit Registry Editor.
- Restart the computer.
NOTE: Use these steps only if you experience the problem that is described in the Symptoms section. If you uninstall and then reinstall the client again, you must repeat these steps.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Systems Management Server 2.0 Service Pack 4.
Modification Type: | Minor | Last Reviewed: | 6/14/2005 |
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Keywords: | kbBug kbfix kbsms200preSP4fix KB310508 |
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