Enabling Acoustic Echo Cancellation and DV Camera/TV Tuner Support in Windows Messenger (310507)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP 64-Bit Edition
  • Microsoft Windows Messenger 4.0

This article was previously published under Q310507

SYMPTOMS

When you use Microsoft Windows Messenger for audio or video conferencing, you may notice an echo or feedback of your own voice.

Also, Windows Messenger has no support for DV camcorders or analog TV tuner adapters.

CAUSE

Support for these features was not built into the released versions of Windows XP. The update that is described in this article enables Acoustic Echo Cancellation (AEC) in Windows Messenger, which eliminates feedback during a Windows Messenger conference call to provide a better audio experience. The AEC feature is available only with Universal Serial Bus (USB) cameras that use Microsoft USB audio.

This update also adds support in Windows Messenger for DV camcorders and analog TV tuner adapters to provide a greater range of supported streaming devices. AEC does not work with DV camcorders; you may want to use a headset for better audio quality.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to Obtain the Latest Windows XP Service Pack

Windows XP Home Edition and Windows XP Professional

The following file is available for download from the Microsoft Download Center:
NOTE: This is an updated version of the "Real Time Client Update for Audio/Video" for Windows XP Home Edition and Windows XP Professional.

Release Date: February 25, 2002

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

The English version of this fix should have the following file attributes or later:
   Date         Time   Version      Size     File name
   ------------------------------------------------------
   12-Oct-2001  14:10  5.1.2601.0   139,264  Aec.sys
   11-Dec-2001  16:43  5.1.2600.16  844,288  Dxmrtp.dll
   06-Feb-2002  15:41  5.1.2600.28  549,888  Rtcdll.dll
   12-Oct-2001  14:22  5.1.2600.16    6,016  Splitter.sys
   27-Nov-2001  14:20  5.1.2600.21   56,832  Usbaudio.sys
   30-Jan-2002  18:07  5.1.2600.28   19,200  Usbuhci.sys
				

Windows XP 64-bit Edition

This update is available on the Microsoft Windows Update Web site. Release Date: October 25, 2001

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on secure servers that prevent any unauthorized changes to the file.

The English version of this fix should have the following file attributes or later:
   Date         Time   Version      Size       File name     Platform
   ------------------------------------------------------------------------
   12-Oct-2001  18:10  5.1.2601.0     279,552  Aec.sys       Itanium 64-bit
   12-Oct-2001  18:22  5.1.2600.16  1,048,064  Dxmrtp.dll    Itanium 64-bit
   12-Oct-2001  18:22  5.1.2600.16     13,824  Splitter.sys  Itanium 64-bit
   12-Oct-2001  18:22  5.1.2600.16    200,704  Usbaudio.sys  Itanium 64-bit
   12-Oct-2001  18:22  5.1.2600.16     68,352  Usbuhci.sys   Itanium 64-bit
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows XP Service Pack 1.

Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbmm kbnetwork kbWinXPsp1fix KB310507