Windows Protection Error When You Attempt to Install Flash 5.0 (310387)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q310387

SYMPTOMS

When you attempt to install and run Flash 5.0 from a Flash-enabled Web site, you may receive a "Windows File Protection" error message.

CAUSE

This behavior can occur if the Flash installation attempts to replace the protected system file Swflash.ocx.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to Obtain the Latest Windows XP Service Pack

An update is available which removes Swflash.ocx from the list of protected operating system files.

This update is available on the following Microsoft Windows Update Web site: Release Date: October 25, 2001

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file. The English-language version of this fix should have the following (or more recent) file attributes:
   Date         Time   Version      Size       File name     Platform

   ------------------------------------------------------------------

   16-Oct-2001  12:37  5.1.2600.16  1,560,576  Sfcfiles.dll  i386
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows XP Service Pack 1.

MORE INFORMATION

To download the Flash Player, browse to the following Macromedia Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kberrmsg kbfix kbsetup kbWinXPsp1fix KB310387