You receive an error message when you click a hyperlink in Outlook (310049)



The information in this article applies to:

  • Microsoft Office Outlook 2003
  • Microsoft Outlook 2002
  • Microsoft Outlook 2000

This article was previously published under Q310049
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you click a hyperlink in Microsoft Outlook, you may receive the following error message:
This operation has been cancelled due to restrictions in effect on this computer. Please contact your system administrator.

CAUSE

After you upgrade to Microsoft Internet Explorer 6.0, the following registry key is either missing or corrupt:

HKEY_Local_Machine\Software\Classes\htmlfile\shell\open\command

RESOLUTION

You may be able to resolve the issue by resetting Web settings in Internet Explorer. If that does not resolve the issue, import the registry key from another computer.

Reset Web settings

  1. Start Internet Explorer.
  2. On the Tools menu, click Internet Options.
  3. Click the Programs tab, and then click the Reset Web Settings button.
  4. Under Internet programs, verify that the correct e-mail program is selected.
  5. Click to select the Internet Explorer should check to see whether it is the default browser check box.
  6. Click Apply, and then click OK.

    Note You may receive the following message when Internet Explorer starts:

    Internet Explorer is not currently your default browser. Would you like to make it your default browser?

    If you receive the message, click Yes.

Export and import the registry key from another computer

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Export the registry key from another computer

  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. Locate the following registry key: HKEY_Local_Machine\Software\Classes\htmlfile\shell\open\command

  4. Click the command folder.
  5. On the File or Registry menu (depending on your operating system), click Export.
  6. Note the location of where the file will be saved. The registry file can be saved directly to the hard drive or floppy disk.
  7. Type a unique file name, and then click Save.
  8. Quit the Registry Editor.

Import the registry key

  1. Copy the Exported registry key to the desktop on the problem computer.
  2. Double-click the .reg file.

    You receive the following message:

    Are you sure you want to add the information in drive: location file was copied to\file name.reg to the registry?

  3. Click Yes, and then click OK.

Modification Type:MajorLast Reviewed:6/9/2005
Keywords:kbRegistry kberrmsg kbnofix kbprb KB310049