FIX: Visual FoxPro 7.0 Stops Responding if Immersion Desktop Software Is Running (308606)



The information in this article applies to:

  • Microsoft Visual FoxPro for Windows 7.0

This article was previously published under Q308606

SYMPTOMS

When the Immersion Desktop 2.1 software that comes with the IFeel Logitech mouse is running, Visual FoxPro 7.0 may stop responding upon starting or soon thereafter.

Earlier versions of Visual FoxPro do not have a problem with the Immersion Desktop 2.1 software.

CAUSE

Visual FoxPro 7.0 does not run properly if the Immersion software is already running.

RESOLUTION

To resolve this problem, obtain the latest service pack for Visual FoxPro for Windows 7.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

316964 How to Obtain the Latest Visual FoxPro for Windows 7.0 Service Pack

To work around this problem, turn off the Immersion software.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Visual FoxPro for Windows 7.0. This problem was first corrected in Visual FoxPro for Windows 7.0 Service Pack 1.

MORE INFORMATION

The Logitech IFeel mouse comes with software created by Immersion Software. This software makes the mouse vibrate when the cursor passes over an object that performs an action when clicked; for example, a hyperlink or a button object.

Steps to Reproduce Behavior

  1. Install the Immersion software that comes with the Logitech IFeel mouse. You can also download this software from the Logitech Web site: Follow the links to the IFeel mouse and select the Download Software link. The file name is IMMDESKTOP21_ALL.MSI.
  2. After the software is installed, you will see an icon on the Windows Taskbar that looks like a hand. (An Immersion Desktop tool tip appears when you move the mouse over it.)
  3. Click Start, point to Programs, and click Microsoft Visual FoxPro 7.0. Note that Visual FoxPro stops responding upon starting or shortly thereafter.
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:2/14/2002
Keywords:kbbug kbDSupport kbMiscTools KB308606