PRB: VFP ODBC Driver Causes Various Errors in Microsoft Products (308215)
The information in this article applies to:
- Microsoft ODBC Driver for Visual FoxPro 1.0
- Microsoft ODBC Driver for Visual FoxPro 2.0
- Microsoft ODBC Driver for Visual FoxPro 3.0
- Microsoft ODBC Driver for Visual FoxPro 4.0
- Microsoft ODBC Driver for Visual FoxPro 5.0
- Microsoft ODBC Driver for Visual FoxPro (Build 6.00.8281.00) 1.0
- Microsoft ODBC Driver for Visual FoxPro (Build 6.00.8281.00) 5.0
- Microsoft ODBC Driver for Visual FoxPro (Build 6.00.8281.00) 6.0
- Microsoft ODBC Driver for Visual FoxPro (Build 6.01.8629.01) 6.0
This article was previously published under Q308215 SYMPTOMS
When you use the Visual FoxPro ODBC driver to retrieve data, you may receive the following error messages in various Microsoft products:
If you use a Visual Basic 6.0 application to access Visual FoxPro data, you may receive the following error message:
ODBC Error: Cannot open file <drive letter>\<folder>\*.tmp
NOTE: Where <drive letter> represents the drive and <folder> represents the folder that Windows uses to store its temp files.
CAUSE
These errors occur because the System attribute is set at the TEMP folder of the computer. This error seems to occur only on Microsoft Windows NT 4.0, Microsoft Windows 2000, and Microsoft Windows XP operating systems.
RESOLUTION
From a command prompt, issue the ATTRIB -S C:\WINNT\TEMP command to remove the System attribute from the TEMP folder. This assumes that the C:\WINNT\TEMP folder is the default for the TEMP and TMP environment variables. To determine this, right-click the My Computer icon on the desktop, click Properties, click Advanced, and then click Environment Variables. Look at the TEMP and TMP variables in the System Variables list box to determine which folder the variables are pointing to and then issue the ATTRIB command on this folder.
Modification Type: | Major | Last Reviewed: | 12/3/2003 |
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Keywords: | kbprb KB308215 |
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