Remote Assistance May Not Connect to a Multiple-Homed Windows XP Computer with the Personal Firewall Feature Enabled (308210)
The information in this article applies to:
- Microsoft Windows XP Home Edition
- Microsoft Windows XP Professional
This article was previously published under Q308210 SYMPTOMS
When you use a multiple-homed Windows XP-based computer with the Personal Firewall feature enabled, remote users may not be able to connect to the computer in response to a Remote Assistance request.
Also, if you are using a Windows XP-based computer with one network adapter and a modem with the Personal Firewall feature enabled, Remote Assistance does not open the firewall port on the modem connection.
CAUSE
This problem occurs because Remote Assistance opens the firewall port only on the first bound network adapter of the multiple-homed computer.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
322389 How to Obtain the Latest Windows XP Service Pack
This update is available on the Microsoft Windows Update Web site.
Release Date: October 25, 2001
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to Obtain Microsoft Support Files from Online Services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.
The English-language version of this fix should have the following file attributes or later:
Date Time Version Size File name Platform
---------------------------------------------------------------------
05-Oct-2001 11:47 5.1.2600.15 135,680 Rdchost.dll Intel
05-Oct-2001 11:47 5.1.2600.15 131,072 Sessmgr.exe Intel
05-Oct-2001 11:47 5.1.2600.15 470,528 Rdchost.dll Itanium 64-bit
05-Oct-2001 11:47 5.1.2600.15 427,520 Sessmgr.exe Itanium 64-bit
WORKAROUND
To work around this problem, use any of the following methods:
- Change the binding order of the network adapters.
- Temporarily disable the Personal Firewall feature while you receive Remote Assistance.
- Manually open the Remote Assistance ports.
Note that if there is only one network adapter and a modem and you change the binding order, the problem is not resolved.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows XP Service Pack 1.
Modification Type: | Minor | Last Reviewed: | 9/26/2005 |
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Keywords: | kbHotfixServer kbQFE kbbug kbFirewall kbfix kbSysAdmin kbWinXPsp1fix KB308210 |
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