Cannot Change Your Password During the Logon Process (308178)



The information in this article applies to:

  • Microsoft Windows 95
  • Microsoft Windows 95 OEM Service Release 95
  • Microsoft Windows 98
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows Millennium Edition

This article was previously published under Q308178

SYMPTOMS

If your domain password must be changed (because it is expired) when you log on to a client computer, a dialog box with one of the following error messages may be displayed:
Your password has expired.

The domain password you supplied is not correct, or access to your logon server has been denied.
Clicking OK may return you to the Enter Network Password dialog box instead of the Change Password dialog box. You must reboot the computer to change your password.

This problem can occur on a client computer running Windows 95, Windows 98, Windows 98 Second Edition, or Windows Millennium Edition (Me) if both of the following conditions exist:
  • The validating domain controller is running Microsoft Windows 2000 or Microsoft .NET Server.
  • Another user with an expired password has already logged on, changed his or her password, and then logged off of the client computer.
Typically, the following message is displayed when a user attempts to log on to a domain with an expired password.
Your password for Domainname has expired. You must specify a new one to log on.
Notes:
  • This problem does not occur if the client computer is validated by a Microsoft Windows NT-based domain controller.
  • Installing the Directory Service client for Windows 95, Windows 98, or Windows 98 Second Edition, or any associated hotfix, has no effect on this problem (this item does not apply to Windows Me).

CAUSE

Session management between the client and the server results in an unexpected internal error code being presented to the client logon function, which prevents the client from presenting the typical password-change functionality. Note that the server returns the proper error code to the client. This error code is: (2242) NERR_PasswordExpired, "The password of this user has expired." This problem is caused exclusively by the client.

RESOLUTION

Microsoft recommends that you reboot the computer if you encounter this problem.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:12/17/2004
Keywords:kbenv kberrmsg kbnofix kbprb KB308178