PIP: "A Required File, Openscn5.dll Is Missing" Error Message Appears When You Try to Start Picture It! (308119)



The information in this article applies to:

  • Microsoft Picture It! Photo 2002
  • Microsoft Picture It! Publishing Platinum 2002 1.0
  • Microsoft Picture It! Publishing 2002, Gold, version 1.0
  • Microsoft Picture It! Photo Premium 2002, version 1.0
  • Microsoft Picture It! Express 2002 1.0
  • Microsoft Picture It! Photo Premium version 7
  • Microsoft Picture It! Photo version 7
  • Microsoft Picture It! Digital Image Pro version 7
  • Microsoft Picture It! Publishing 2001
  • Microsoft Picture It! Express 2001
  • Microsoft Picture It! Photo 2001
  • Microsoft Picture It! Photo Premium 2001
  • Microsoft Picture It! Publishing 2001 Gold
  • Microsoft Picture It! Publishing 2001 Platinum
  • Microsoft Picture It! Publishing 2001 Silver, when used with:
    • the operating system: Microsoft Windows 2000

This article was previously published under Q308119
WARNING:This information is preliminary and has not been confirmed or tested by Microsoft. Use only with discretion.

SYMPTOMS

When you try to start Microsoft Picture It!, you may receive an error message similar to the following:
One or more components are missing or broken.
When you click Help, you receive an error message similar to the following:
A required file, file_name.dll is missing.
Note the file name that appears in the error message.

CAUSE

This issue may occur if any of the following files are not correctly registered or copied during installation:
  • Openscn5.dll
  • Pitkres5.dll
  • Piapres5.dll
  • Openscn6.dll
  • Gtv6.dll
  • Cpitv6.dll
  • Openscn7.dll
  • Stv7.dll
  • Sctv7.dll
  • Sbox7.dll.

RESOLUTION

To resolve this issue, copy the file_name.dll that appears in the error message from your Picture It! CD-ROM and register it:
  1. Insert your Picture It! CD-ROM into your computer's CD-ROM or DVD-ROM drive.
  2. Locate on your hard disk the file_name.dll that appears in the error message by doing the following:
    1. Click Start, point to Search, and then click For Files or Folders.
    2. In the Search for files or folders named box, type the file_name.dll.
    3. Change the Look in box to the root of your drive. For example, change the Look in box to drive C.
    4. Click Search Now.
    Note where the file is located on your hard disk.
  3. Browse to the file on your CD that appears in the error message.
  4. Drag the file to the folder that you noted in step 2.d. If you are prompted to replace the existing file, click Yes.
  5. Click Start, and then click Run.
  6. In the Open box, type the following

    Regsvr32 drive:folder_path\file_name.dll

    and then click OK.
  7. If more than one file name appears in the error message, repeat steps 2 through 6 for each file.
  8. When the registration process completes, start Picture It!

Modification Type:MinorLast Reviewed:1/9/2006
Keywords:kberrmsg kbprb KB308119