PRB: Bad Password Error Occurs When You Create or Change AD User Profile (308108)



The information in this article applies to:

  • Microsoft Commerce Server 2000 SP1

This article was previously published under Q308108

SYMPTOMS

When you create a new user with the mscsNewRegisteredUserProfile function, the call may fail with the following error:
Commerce Event 4096
<Site Name> File: <ASP FILE>; Function: mscsNewRegisteredUserProfile(); Error occurred. Error Number: -1056948604 Error Description: Bad password encountered.

CAUSE

This error message can occur for different reasons. For additional information about how this error can occur, click the article number below to view the article in the Microsoft Knowledge Base:

292573 ADSI SetPassword Call Does Not Always Set the Password on Target DC

Another possible cause may be because of the way the passwords are changed. By default, the user_security_password is Multi-valued. Commerce Server checks for either one password or two passwords. Microsoft recommends that you change the user_security_password to Single-valued.

RESOLUTION

If you experience the problem that is detailed in the Knowledge Base article that is listed in the "Cause" section, install the hotfix that is listed in that article.

To address the other potential cause, set the User Password to single valued. To do this, follow these steps:
  1. Open the Commerce Server Manager, and then click Global Resources.
  2. Open the Profiles<site name>, click Profile Catalog, and then click Profile Definitions.
  3. Click User Object, and then click General Information in the right pane.
  4. Click User Password, and then click Advanced Attributes.
  5. Click to clear the Multi-valued check box.
  6. Change the ASP code so that it only sets one value.

    NOTE: For an example of this, view the UpdateUserPasswordProperty function in the Save_one_profile.asp file as a guide to write your own code. The UpdateUserPasswordProperty function in the Save_one_profile.asp file is located in the ServicesInclude folder of the Retail and Supplier Active Directory solution sites.
  7. Restart the application.

STATUS

This behavior is by design.

Modification Type:MajorLast Reviewed:10/16/2002
Keywords:kbprb KB308108